NEM Wallet Beta 2.4.2 - Bug bounty paid in XEM


PS: I’m running Nano thru my local Apache, with normal http (80/tcp) port (it could be secure as it is a strictly local connection) … is this the correct way ? I saw there is also Linux desktop Nano app, but even of that, I prefer browser/web access…
PS2: all the previous versions of NCC worked in my browsers (FF, Chromium, Chrome, everything under Linux) without any troubles.


I’ve been tested this issue on another computer (also Linux based), under FF, Chromium and Chrome as well. Same issue in every cases (successful import of *.json file from NCC, then nothing happened after “Upgrade wallet” click). Really strange…


Yes if you were harvesting in NCC you need to deactivate the old remote:

Services -> Manage delegated account -> Use custom key -> Paste your old delegated public key -> Select deactivate -> Send

6 hours later you can go back to Manage delegated account page and just send an activation transaction to activate your new remote (the one shown in the grey input)

Then if harvesting was linked to a supernode you need to update the key in the NIS, enroll again with the new delegated public key and ask @BloodyRookie to deactivate the old entry here: NEM Supernode Rewards Program

Should be secure but you don’t need any local server to run Nano

Okay, strange indeed, it works here… Will look into it for v2.0


if you have more than one account how I can import all my accounts at nano wallet???

I’m just waiting more than 30 minutes, it couldn’t be so long, isn’t ?
No it should take only 1 or 2s, I just tried on Chrome and it worked.

How many accounts do you have in the wallet ?

If you only have one account to import you can simply get the account private key from NCC and create a private key wallet with it in Nano.


Ok, thanks, I’ll do it thru this way…

Ok, but if I don’t want (or don’t need) to run linux NanoClient and just use the html pages and *.js, probably I’ll need local webserver (e.g. Apache), is that correct? I’m thinking, if there couldn’t be a trouble, if sign-up/login doesn’t expect app hearing on some appropriate port (?)

What is more strange - I’ve been tried another way - in Nano “Sign Up”, then “Private key wallet”, then put my private key, name of wallet, pass, etc., finally clicked on “Create private key wallet”, and voilla - nothing happened. Looks like the same issue as with importing wallet (*.json) from NCC, so I’m observing (see above), if there couldn’t be some “global problem” with expecting of some another port (than default 80/tcp Apache’s one), or something like this ?


Version 1.4.10

  • New fee structure on Mainnet
  • Added passphrase strength estimator to brain wallet:
  • Brain wallet passphrase requires 40 characters minimum
  • Moved purge button into footer
  • Show an alert asking to change node if not connected within 5 seconds after login
  • Show an alert if user’s brain wallet seems weak (< 40 characters)
  • Minor fixes and improvements


@jelin1984 You can try to follow this Upgrade works for me, should work for you too.

@KloNEM No need for a local webserver, you can click on start.html and it will open in your browser. Everything is client side, it does not expect any port or else for creating wallets.

Are you using latest version ? Can you open the browser console, try to create a private key wallet and look if you see any red error message.

Don’t paste console content here, send it to me via PM.


kindly remind :slight_smile:


Hi Team. @Saul
The download page is still ver1.4.3.
Please update to the current latest.


Eh, my fault! I really don’t know, why I was expected, that Nano has to be running over TCP/IP / webserver, and not just “as local files”. So, I did it by this way, click on “Upgrade wallet” and everything is running smoothly and fine now. Thanks and sorry again!

Just a question - also in this case (“Upgrade JSON/existing NCC wallet”) I have to deactivate delegated harvesting in old NCC and (after 6 hours) just do activation in “Manage delegated account” in Nano ?


There is now a 5,000 XEM bounty for issues reported to QM’s Github.

Any bounties for bugs in the Android wallet?


Version 1.4.13

  • Allow sub-namespaces and mosaic names to start with a number
  • Fix secondary accounts: In occasional cases, secondary accounts private keys can start with ‘00’ but BIP32 was omitting it, giving a 62 characters private key. Those secondary accounts will fail to send anything out even if password is valid (but recoverable).
  • Update languages


Yeah, you can also deactivate the old remote account from Nano directly by providing it’s public key


New bug bounty system is posted on the website


I´m supprised. In the new Version 1.4.13 (simple Wallet) we can read " It is still recommended to use a private key generated from a NEM client (NCC). " . The NCC support has expired.
Should we change it in the next version?


Where was the document recommending the secret key of NCC?
Basically, there is a problem with using BrainWallet with NanoWallet.
In the latest NanoWallet, when using BrainWallet, you can not register unless the password has a certain degree of complexity or more.
Also, if you are using a weak password in BrainWallet, you will now get a warning.



When I start the universal client —> Sign up —> Simple Wallet .


Oh, lol
There is no problem as long as you use Simple Wallet.
I will fix this document.


Yep, but for some new user maybe it´s a bit strange with the good old NCC.


Is bounty program actual?