1000 XEM bounty to the want that fix my problems

Multisignature delegated harvesting is an advanced feature that can be complicated if you don’t know what you are doing.

There was an information tab that disapeared but basically it was saying:

Only the cosignatory that initiated the importance transfer can active / deactivate and start / stop harvesting.

This is why it worked only with one cosignatory. Each cosignatory have an unique remote account associated to it.

It is not possible to know what is the remote account of the multisignature account if you are using a cosignatory that have not initiated the importance transfer.

To try fixing your issue you need to log into the cosignatory account that activated the importance transfer, go to “Manage delegated account of multisignature accounts”, type your password, select the account.

Now look at the status:

I - If it says “ACTIVE” it means you have a remote activated.

In this case got to explorer: http://chain.nem.ninja/#/blocks/0, paste your multisig account address to check on the explorer and see if the remote account is corresponding to your cosignatory’s dedicated remote.

In that case you can choose a node and press the start button.

Otherwise you need to find the cosignatory account that has the right remote to start.

II - If it says “INACTIVE” it means you have no remote for your multisig account.

You should be able to send an importance transfer to activate from any of the cosignatory.

Well that doesn’t make sense at all with my case because i remember i started the importance transfer with cosignatory 1, which is the issuer account starting with NABO35

Multisignature importance transfer transaction
Fee6.000000 XEM
Multisig fee6.000000 XEM
TimestampFri, 14 Apr 2017 17:15:44 GMT
Hash d30fa30cacdfdc2016baf56796f645f6879377b593ec7f135af462e14c6206e2
Multisig hash7c29d6f90443cfdad1072eac67872478cbb0f91d65888af39ed83d4a837aa5be

And end up deactivating importance transfer with cosignatory 2 account starting with the address NA4ZQ5 as the issuer.

Multisignature importance transfer transaction
Fee6.000000 XEM
Multisig fee6.000000 XEM
TimestampThu, 20 Apr 2017 15:34:52 GMT
Hash bb69734eb564ded05eb73b136864a85f8565699e6bf15a0f6d8cb18bdacad7e5
Multisig hash1a7047c2bea3d43b900686b458c3299e4a48ed5fd8f22d5ebb62dc45f09bb419

I’m beginning to think that that since i started multisignature service in nano wallet everything fucked up.
Because the problems started when i activated that shit. Maybe if i turn that off i can local harvest again? or delegate harvest normally? I don’t know what else to do… since april 11 not finding a single block :confused:

It is pretty clear to me that you are trying to do to complicated things to begin with. I understand you want to make the Harvesting earnings available to both of you and your brother, so create a new account my_family.

Then, also create a new account log_wallet, and another new account my_brother. Now with log_wallet, go to Services > Convert an account to MultiSig. Select the Import Key tab and insert the Private Key of my_family and send the aggregate modification transaction. now the account is a multi sig account. and the issuer which QM mentioned is the account log_wallet [because we used yours to convert the account to a multi sig account].

Then with the log_wallet account you should send the importance transfer transaction with mode activate. Wait 6 hours and then, also with the log_wallet account you should select a node to start harvesting. That’s how it looks, clearly and broken into steps. I believe you are trying to complicated things and you should read a lot on this forum, the guides, etc. they can help :slight_smile:

One more thing, once you have converted an account to Multi Sig, you cannot undo it. More generally, we are talking money here, so be very careful and I can only say prevention is better than cure, try documenting more before you step into complicated systems where you lockup your funds in MultiSigs. :slight_smile:

hope I could help a little,
Take care!

Why you want me to create a multi signature if i already own one? multi signature shouldn’t be complicated… I have one main account with all the XEM in it and 2 cosignatories. I don’t want to sound toxic or anything but i’m not stupid, i have the private keys of the 3 accounts, i am able to send xem to whatever xem address i want, requested by any of the two cosigners , xem that is taken from the main account and signed by the other cosigner left. So i don’t know what you mean, i made things correctly according to what i investigated. Before converting to multisig i read how to do it, that’s why i’m telling you.

What quantum mechanics said doesn’t make sense or at least not in my case. Cosigner 1 sent the activate importance transfer and was signed by cosigner 2. And cosigner 2 sent the deactivate importance transfer and signed by cosigner 1. So what @Quantum_Mechanics says is either wrong or this is the MATRIX and my multisignature accounts are NEO of the matrix, i have those two activate and deactivate importance transfers registered in my wallet with different issuers i can show you screenshot if you want. I had to do it that way because there was no way to send the deactivate importance transfer by cosigner 1. And now i can’t even send the importance transfer with cosigner 1 anymore. According to what @Quantum_Mechanics said, only cosigner 1 can send the activate importance transfer and also cosigner 1 is the only one that can deactivate it, well… not true and my screenshots proves it.

http://prntscr.com/f0f1c0 Activate importance transferer issuer was cosigner 1

http://prntscr.com/f0f1ld Deactivate importance transfered issuer was cosigner 2

Indeed I have been mistaken on that, you can actually deactivate from any cosignatory, it was specified in the message that has disapeared. Got to go right now but will try to figure out your problem asap

I just tested, wanted to send 100 XEM from cosignatory 1 to another wallet address that i just created. But cosignatory 2 won’t receive the transaction so he can sign it? I freaked out and i tried to send from cosignatory 2 100 xem to that wallet address and cosignatory 1 indeed received the transaction to sign it in cosignatory 1. Why cosignatory 2 can’t see the transactions requested by cosignatory 1? All this is really really not working for me. I experienced exactly the same the other day…

The only account that can request to send funds is cosignatory 2 and that should not be. i’m afraid that one day will come that it won’t be possible to sign anything in either of cosignatories because the transaction to sign won’t appear in both. I’m scared.

Screenshot, http://prntscr.com/f0fbh5 first transaction was requested from cosignatory 1 and second transaction was requested by cosignatory 2 and the second one appears that i can sign it with cosignatory 1, i’m not in the computer of my brother but if you see his wallet you won’t see anything to sign there.

my apologies for jumping to the conclusion that you would do to complicated things, laid out in details it doesn’t seem complicated at all and now I understand your problem.

Both accounts should be able to send transactions, you are right there. Question here: is cosigner 2 consistently refusing to catch transactions initiated by cosigner 1 ? or did that happen only once? (there is an open bug about websockets not catching multisig transactions if i recall correctly) Logging in / out would usually solve the issue of the transaction not appearing!


As a matter of fact I see unconfirmed transaction in cosignatory 1, so if you sign out that account, and sign back in, you should see the unconfirmed transaction and be able to sign it.

Is constantly refusing to catch transaction initiated by cosigner 1.

As a matter of fact I see unconfirmed transaction in cosignatory 1, so if you sign out that account, and sign back in, you should see the unconfirmed transaction and be able to sign it.

Yes i haven’t sign that transaction because i was testing if cosigner 2 effectively could request a transaction and appear to confirm in cosigner 1 account, and yeah cosigner 1 can receive unconfirmed transaction normally from cosigner 2. The problem is the other way around. I know that if i sign it the funds will be released but i was just testing.

Can you also see a unconfirmed transaction in cosignatory 2? i am in http://chain.nem.ninja/ but i don’t understand well that explorer and how to see the unconfirmed transactions there. I sent 107 XEM transaction with both cosigners but i can only see a unconfirmed transaction ready to sign in cosigner 1 wallet.

logging out and logging back in cosigner 2 wallet won’t make the unconfirmed transaction appear.

Because there is an issue with unconfirmed multisig transactions. I have added a workaround on my local version that is working and fix that problem.

Next version will be okay with that.

About your harvesting problem, http://chain.nem.ninja/#/search/NDYQE4-HBRS2T-5ZWBGU-FHS5V4-O2HXQ2-KMHUTR-T6JF here I see you have no remote activated. Send an importance transfer from one of the cosignatory (if you can) and wait 6 hours for activation. Then log into the same cosignatory and you’ll be able to choose a node and click on start button

I just try logging out from cosig2 and logging back in, and it worked, now i see the unconfirmed transaction! Damn i was scared one day neither of two would be able to see unconfirmed transactions.

Great, no worries if the unconfirmed multisig transactions don’t show up. They just die after 24 hours and you lose no XEM.

I deactivated that long time ago because it wasn’t finding blocks for 3-4 days so i gave up, also the only way to deactivate it was from cosigner 2 because cosigner 1 was showing an error (“failure transaction not allowed for remote”) i already posted in the first post. Now i’m local harvesting and at least is finding empty blocks.

I’d like to know now why i can’t initiate activation importance transfer from cosigner 1 (or deactivation) i only can do it from cosigner 2 and the problem i have of market data not showing up?

I need to reproduce the error to know but there is a lot of possible causes. If you start messing with activations and deactivations with different cosignatories it could cause problems I guess, I think I got a report about “failure transaction not allowed for remote” will ask devs.

About the market data issue I have no idea. No one else reported the issue so if you use latest Chrome or Firefox and see no difference it is definitely on your side.

But what could be? I don’t have firewalls or anything that might be blocking market data, the computer of my brother and my computer both have the same problem. I thought it was my ISP provider but i also tried with my cellphone internet and nothing. So what might be? I hate the fact that i am the only person in the planet that i can fetch market data for some unexplainable reason. I tried with chrome and firefox and opera and nothing, i have the most recent chrome version, firefox version, nano wallet version.

Console say this every time i connect to a node.

start.html#!/dashboard:1 XMLHttpRequest cannot load https://poloniex.com/public?command=returnTicker. No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'null' is therefore not allowed access. The response had HTTP status code 403.
main.js:112823 recenttransactions data:  Object {data: Array(13)}
main.js:112860 Unconfirmed data:  Object {meta: Object, transaction: Object}

Also console of nano wallet give me this warning http://prntscr.com/f0hlau

what is that pascalprecht. it says that can have serious security implications.

Any update? Thank you.


Not yet, I have a lot of prioritary work and your funds aren’t at risk with these bugs.

This warning is from the Internationalization (i18n) module. It is normal, I don’t think it is a security issue as Nano works locally. But in case of an online version I guess it would be sensitive because someone could inject code from there without sanitization strategy.

Ah ok, i’ll wait. I just hope you guys help me to fix these problems one day via teamviewer or something. You guys better than me can identify the problem of market data :smiley:

The market data problem is my internet, my friend just bring his computer to my home and have the same problem with his wallet. What could it be?