Connect to NIS on EC2 from remote


I’m running a NIS server on EC2 instance, the server is fully synchronized and work properly
I can curl to NIS server by using its private ip from other server (on the same EC2 group), but i cannot curl from remote (my personal computer) using public ip, the connection is always refused.
I tried ping from my pc to EC2 public ip and it worked, but when i curl to EC2 public IP on port 7890, it refused my connection
I opened port 7890 on EC2 instance with ufw, i also configured openning port at EC2 dashboard, but no luck
My node also not displayed at NEM testnet node list :frowning:
Sorry for my bad english !
Please help!

1 Like

Port 7890 (for API) and 7778 (for websockets) should be open.
I didn’t use EC2 but it should be somewhere possible in configuration.


thank pawelm,
after a lot of try, i totally rebuild server :smile:
now i’m going to list FMT (a NEM mosaic) on my exchange, can you give me some guide, installation step or any preparation for listing NEM mosaic on an exchange?


You can look at this tutorial:


i’ve read api document at
but this document is lack of historical query guide such as transaction lookup, address transactions history…
do you know where i can find full document?