Error when I press 'Start delegated harvesting'

I guess my knowledge is not the same level as yours,

For the questions you ask. I give my best guess.

Tell me the screen which contains the address you are referring to.

I have both the Mobil NEM and the PC version.

The Remote account and the Delegated public key on the screen print I sent, are not changeable fields.

The only changeable fields are for the 2 passwords on the right side of the screen, which I have entered.


Saul when you return I can supply the screen print of the ‘Manage delegated account’ with the error. The only two fields that are editable are the password fields. The ‘Harvesting Status’ is inactive. I have tried several different nodes and I have pressed the ‘Start delegated harvesting’: - the Inactive "Harvesting Status’ remains and the error code then appears.



If you ask questions here, can you create a new thread?
There is almost no writing in Japanese, so I would like to make it an independent thread.

Here I am constantly accepting support in Japanese only because I am,
If possible please request support from the following URL.

Sure, screenshots are usually helpful.

Good Afternoon Saul. Here is the screen shot.

Please paste your address here.

Did you activate harvesting via Nanowallet, or another wallet/method.?

NBU5Z7-NHTFIX-LFFWDY-QTZXF2-KKDXSB-NBDITI-7DWW . Yes I paid 6 XEM and tried to activate harvesting via Nanowallet…

At NanoWallt, have you imported your private key, such as changing your password or changing your Wallet name?

Currently, “NDMN7U-ZUBG2Q-NLZCN5-UCD6FL-XWTQYQ-4UXBRB-UVTK” is set for the remote key of your account.

It is not a remote account displayed on the screen.
For this reason, the NanoWallet returns an error.

In this situation, you need to deactivate the previously activated remote account.

Please check “Use a custom public key”.
Then enter the following Public key.
Then select “Deavtivate” and issue a transaction.

Approximately 6 hours later, you will be able to activate again, please issue a transaction of Activate with the current RemoteAccount.
After 6 hours, you can set up the harvest.

If you see an error in the middle, please write it here.



I am wondering how you activated your delegated harvesting account originally, was it via NCC?

Follow @mizunashi advice, it should solve the problem.

I followed your steps. I deactivated, then again activated. This is the error I receive now when I try to start delegated harvesting.

‘Error at unlocking account, reason: blocking private key request with non-configured address NBWDS7HEWSE5HWFYVPODQPM7BUDBT4INU6EVWZE3’

Please try restarting NanoWallt.
I think that there is no problem setting, so please try once.

Thank you.

1 Like

It is addition.
Could you please try changing the NIS server?

Thank you.

1 Like

Hi Mizunashi and Saul

I switched the NIS server and the ‘Harvesting Status’ changed to Active; the button I press to ‘Start delegated Harvesting’ turned to light red and displayed ‘Stop delegated harvesting’. I will let you know when I received my first harvested fee.

Thank you Mizunashi and Saul for your time and intelligence in this matter.



Good luck!

1 Like

Currently, some official nodes have block chains not synchronized.

Please change the setting of NIS server in node setting to one with alice.
First of all I want to do it and confirm the operation.

There is no problem if this screen appears.

If harvesting stops, it will be when the delegating server is restarted. Taking this screenshot as an example, if stops even once, the harvesting will remain stopped.

In case of manual work, you need to check this screen everyday.

We have a project to make it semiautomatic / fully automated, so I will introduce it.


1 Like

Thank you Mizunashi. I will use both tools. You have brought light to my day … Thank you… Patrick

same problem…