Locating wallet on Mac ios?


#6

Sir thanks for your help, but like i’ve said there is no .wlt file anywhere to be found .Nem developers should be specific on where this important file is located on type of System & Browser being used. if i don’t find this file… will eventually sell all my nem currency


#7

I think it is a very important opinion.

There are other problems with .wit file output.
And that problem has been reported and improved by developers.


#8

Guys,

call for help. @Quantum_Mechanics or anybody else…
We had one wallet with a quite some XEM inside which was run on a MAC through SAFARI with no private key backup.

For certain web application testing reasons the cookies got deleted after some months of smoothly running NanoWallet since late 2016. Now, I am helping to recover / find the .WLT file on that Mac (Downloads folder had never been cleaned). There is no .WLT file neither any “Unknown.” file.

I tried to recover deleted files but no Cookie files recovered.
Then, I tried to set up a new Simple Wallet in NW 1.3.0 and reproduced the error that no wallet file download is offered to the Browser at all. No file downloaded.
Tried on same Mac in Chrome, wallet.wlt got downloaded.

  1. i want to raise awareness of this possible little “bug”
  2. does anybody have another idea for recovery? (we have Acc.Add. & pub.key and obviously access to the Mac)

R.


#9

Hi,

I know about the “Unknown” wallet problem, I will fix it asap. Maybe it is possible that it does not download the file depending your version of Safari…

I’m afraid that you have not the wallet in that case, unless you dowloaded it and moved it somewhere else…

I am not sure if it is possible to recover local storage data (not cookies, it is different)


#10

@Quantum_Mechanics
What’s the filename of NanoWallet “Local Storage” file which the browser creates?
I understand that for MAC OS with Safari we are looking at the folder ~/Library/Safari/LocalStorage/ , right?
R.


#11

Same Problem, I did find unknown files and they are wallets but im not sure what kind.
Renaming to .wlt would not load, what does the data in the wallet file look like? does it need to be in a certain folder to load?

This needs a fix. Thanks


#12

You must re-import that data with the “Import Wallet” button, then it will be stored in your browser’s localStorage again.

if you have a PHP installed and are a linux user you can actually “decrypt” the wallet data to know which wallet is concerned by the retrieved file (see the name, address, child wallets, etc…):

$ php -r “echo base64_decode(file_get_contents(’/path/to/retrieved/file’));”


#13

Same problem here.
Started new simple wallet (using nanowallet 1.3.3, mac os and safari) Small test transfer from Polo. Works. Put in all my Xem from Polo. Wrote down pw. Logged out.
Tried to log back in. Oops - safari didn’t download a .wlt file, also didn’t download an ‘unknown’ file. Safari also forgot about the local cache file (basically as soon as the window is closed).
I wish I’d used Firefox - that does download the .wlt file. Stupid safari doesn’t.

tried creating another wallet for testing. Safari really doesn’t appear to storing anything anywhere. Nothing appears in the user/safari folder. A few large history files do update, but doesnt seem like wallet file/private key can be retrieved from there.
or it’s exceedingly difficult.

Any ideas about retrieving the wallet file from somewhere inside my computer? :frowning: I suppose it just hasn’t been stored anywhere.

I feel so dumb, of course I need a private key - should have written that down too. And to think I was transferring my XEM in order to be safe (safer than in the exchange). Should have read the instructions more carefully. But I didn’t expect to loose all practically immediately after logging off. So odd that the wallet really does not seem to be stored anywhere. Or is it?

So - I feel pretty bad. I wasn’t careful enough. lost hard-earned money.
But Safari seems unsafe for using with Nanowallet…


#14

If you haven’t cleaned the browser localStorage, the wallet should still be there on the Sign In page in the list on Safari, isn’t it?

Safari doesn’t download the .wlt file but the localStorage does work for the browser session, that would suggest that your localStorage has some data. Open up Safari and the Javascript Console (probably named something like “developer tools”, not sure as I don’t use a mac) and execute this little command: window.localStorage than hit enter, you will maybe see some data of your wallet there, but not password, nor private key.

If you get in, first thing to do is to go to Account > Backup Wallet:

Hope to help. :slight_smile:


#15

no thats the funny thing - it’s also gone from the sign-in list. It disappeared from that list after I closed the window and reopened the Nanowallet. That’s when Safari also ‘forgot’ the local storage. Your advice - for which I thank you - doesnt show any files.
Firefox on the other hand remembers quite well, it keeps the wallet on the sign-in menu after closing and reopening the brower window.
I’ve tried some tools to comb through my safari cache files but to no avail.
Very disappointing. I’ve been silly myself - but I noted Internet Explorer and MS Edge had been blocked as browsers for nano wallet. Same should be done for Safari I think.


#16

nemnewnie: i have exactly the same problem. have transfered 0.5 BTC using exchangelly to NanoWallet. Now I cannot access it, it’s not shown in the list, Safari didn’t download it etc… Any luck finding the answer?


#18

So, I have a similar issue. I am using Safari. I accidentally deleted the Nano folder (thinking it was the super node program), restored it through time machine. I DO have the private keys, password and had downloaded a main.js file: which the import wallet function is recognizing as the wallet file (I get a confirmation message that it has loaded). I put my password in and try to sign in (or import wallet, as I have tried both) and nothing happens. I believe that I had named the wallet, however, and there is no option to put my name in…it just says “nano wallet” which might be the issue. Any suggestions?


#19

I just sorted this out…might help someone else. Use the Private Key login tab. Insert Private Key, allow the network to populate the address and network (it was mainet which is different than the original one I thought I’d selected). Put in password and confirm password. Within seconds, it found my XEM and my wallet is back up.


#20

I have this same exact problem. I have the wallet address ( where I sent funds too, and I have the password )

The problem is: Safari did not download any files upon my creation of the wallet and the local wallet stored just disappeared? I was under the assumption that a backup file was created immediately but that seems not to be the case.

When you say private key login tab, what happens if I don’t have the private key wlt/unknown file?


#21

i have also the same problem?
created a simple wallet with safari and sent there 0.2 btc XEM and closed it!
i didnt backuped it!
all i have is the adress wallet name and password!
no one knows how to help me!
its unbeliveble that when you close the safari then your wallet and everything is gone!


#22

also have the same problem.
Does someone know how can i restore the local storage library in mac???


#23

Anyone found anyway to solve this yet? - It would be good to tell anyone who is buying NEM for the first time not to use Safari!! This should be highlighted in bold red to stop another unlucky person stumbling on the same problem.

For those that have been caught in this trouble, is there anyway to get our funds back without the private key file?


#24

@Quantum_Mechanics will this “bug” be fixed in future versions of the NanoWallet (re. Safari/MacOS - no .WLT download)?

For those who lost their browser’s local storage (which contains the wallet info - until you purges it intentionally or unintentionally): You may try to use http://www.easeus.com/mac/mac-undelete-free/ or https://www.stellarinfo.com/data-recovery-mac.php
(or check http://www.techrepublic.com/article/3-data-recovery-applications-for-os-x/ )

However, don’t change too much on your harddrive because every write operation may sooner or later overwrite the freed-up space where the “deleted” contents reside.
We need to recover the files from ~/Library/Safari/LocalStorage/ or similar folders.

Try to keep Safari OFF, so it doesn’t mess with the “new” Local Storage files…!
Good luck. We all learn our lessons one way or the other.

Remember: Back up your private keys. If needed, do it manually - it’s easy.


#25

Hi @r3n3,

I have looked and did not found any alternatives for older versions of Safari.

I know exactly what is the problem: https://github.com/NemProject/NanoWallet/blob/master/src/app/modules/signup/signup.controller.js#L103

Support for the download attribute is only since Safari 10.1: https://caniuse.com/#feat=download

Users must use the latest version of the browser as mentionned here: Nano Wallet Beta 2.0.14 - Mandatory update - Bug bounty paid in XEM

I want to add a lock if version below 10.1 but all our current users with Safari will have to update their browser to use the app again


#26

Thanks for the good explanation. @Quantum_Mechanics - This helps to understand the cause of the issue.