Nano Wallet Beta 2.3.2 - Bug bounty paid in XEM


#55

About this bug, we confirmed Pull and Marge in GitHub. Thank you very much.


#56

When it’s seen in Edge, I can’t download my backup wallet file.
I click download icon , but nothing happened.

and I check my developer console, I found no javascript error or any other messages.

ttp://imgur.com/7U0vscz.png

Note: my wallet name is “testnet”.
and I tried on other account, but it was the same result.

Nano Wallet BETA 1.2.2 !
Microsoft Edge 38.14393.0.0


#57

thank you for the report @unknown_bitcoin. We actually hadn’t been testing Edge that much, mainly just Chrome, Firefox, and Safari, but we definitely want it to work on Edge too so we will note that and look at it.


#58

While inputting Namespace, a popup message will appear that displays search results for each input character. I think it is luscious to fluff.


#59

Often times signing can be done many times when signing against transactions of multi-sig accounts.
Since we succeeded by signing even once, there is no harm.
However, as the signable screen comes up repeatedly, it will be like a picture.
An image that has become like I signed three times.

Perhaps it is a specification that can be signed many times until being confirmed?


#60

Version 1.2.12

  • Renew namespace module
  • Renewal alert when namespaces can be renewed (one month before expiry)
  • Fix multisignature module
  • No need to send at least one transaction from an account before converting it to multisig, just send funds to it and convert.
  • Fix apostille request message QR
  • Clean apostilles explorer table to show only HEX messages
  • Fix Balance and vested balance display (dot instead of comma)
  • Fix notarization account cleared when uploading a file in update apostille
  • Fix create apostille still on public after selecting multisig
  • Smaller apostille certificate size
  • Minor design

#61

Thank you for your patience.
I have confirmed the points that have been modified variously.

I’m happy that ImportanceValue can be written in the same way.


#62

Hi,

I’ll find a better way to handle that, maybe by showing “Not a valid alias !” into the “Alias of” input instead of alerts.

When you sign it does not remove the bottom bar and the red message ?

Will be in next update :slight_smile:


#63

That’s right.
Since this phenomenon has experienced multiple times not only once, it has reproducibility.
When a sign request arrives, I guess that you are probably able to actually sign on the first sign.
However, on the screen, I will be able to sign again in order to become the same screen as before signature even after signing.
It is a multisig configuration of 6 of 12 in the production environment of main net.

Finally, although it is a little away from the subject, I will introduce an example where the signer can not easily sign the multi-sig’s signature request.
If a signature request occurs, there are times when it takes time or signature request does not arrive at all (even if the required number of signatures has not been reache), even if the signer invokes the signature to sign the NanoWallet.
I am thinking that the signature request is a push send.
And the signer who does not receive the signature request is a bit confused.
As a temporary countermeasure at present, signing request may be sent by NIS node change now, so we are dealing with that (even if it does not come yet).

I almost depend on automatic translation, so I think that it is hard to read, but thank you.


#64

1.2.12 < 1.2.2


#65

What browser are your using ? When the issue occurs can you open the browser console and see if any errors are shown ?

Yes sometimes cosignatories do not receive the transaction to sign and changing node can fix the problem. This issue is here since the first version of the app, not sure why. I suspected NIS but I don’t remember the reason, maybe it was also in lightwallet.


#66

No, it looks confusing but 1.2.2 < 1.2.12

2 is less than 12.


#67

For the case where I can sign many times, try checking the console log next time. Currently I’m using the latest version of Google Chrome (MacOS).
And, as for the case where the signature request does not arrive, I understood it as a problem that existed before.


#68

Problems occurred only when using Chrome V.56 (latest version) in NanoWallet β1.2.12 (Ver. 2016 Nov and Ver. 2017 Jan).
There is no problem with Chrome V.55.

When updating from V.55 to V.56, localStrage will be deleted once, regardless of whether it is checked or not.

From Chrome V 56, if the checkbox of “Block third-party cookies and site data” is checked, it seems that the localStrage has turned into a design that can not be seen.

So, when using Chrome V.56, we need to uncheck it.

By the way, in Chrome V.55 localStrage was visible even if checked.


#69

I found a new bug that only happens when using the latest Google Chrome (V.56).

At the Apostille notarization creation menu, the fee will be remitted but the Zip file can not be downloaded.

Looking at the console log, it seems that I am trying to access the cettificate.png file and it is a CORS policy violation.
Here is the screen at that time.


#70

Hi,

Indeed, this issue was also in Safari. It has been fixed a couple days ago by fetching the certificate from Github repository if using those browsers.


#71

Thanks for the report. As QM said, the next release will have this fixed.


#72

Hi,
I’m using the english language.
If I go from

Services

Delegated Harvesting
clic on "Manage delegated account"
In the harvesting panel on the bottom,
there is a combo box,
"Select a node to harvest on"
on the right of this combobox, there are three buttons from left to right:

1 - "use custom node"
2 - "use node from list"
3 - “start delegated harvesting”

well, the description of 1 should go to button 2
and the description of button 2 should go to button 1


#73

I have logged two issues on GitHub:
#13 - In Microsoft Edge after upgrade of NCC wallet you are not prompted to download the upgraded wallet and manually trying to download the wallet from Account does work either.
#15 - Microsoft IE 11 rendering on pages is broken. Probably down to IE 11 but might want to include supported / recommended browsers on the initial splash screen

KC


#74

@quasarblue, Will be fixed in upcoming 1.3.0

@KingCole, I’ll probably lock the app and show a splash screen with recommended browsers if an unsupported one is used.