Running a NEM Node on a Raspberry Pi


#22
./nix.runNis.sh

means run from current directory

to make this work you should first change directory with cd "/path-directory/package/"
or whatever is called on your system and then you will be able to
run the script as described above.

You could maybe try create a separate bash script that does the above:

#!/bin/sh
cd /path/package/
./nix.runNis.sh

and call that

or maybe you could try the following absolute path with systemctl:

/path/package/nix.runNis.sh

Let me know if that worked for you.


#23

Hi Freigeist thanks for helping. I have created a new bash script and change the systemctl file to test but still no good. This is what I got at the cmd line:

[email protected]:~ $ systemctl status nemNode
● nemNode.service - nem node
   Loaded: loaded (/etc/systemd/system/nemNode.service; static)
   Active: inactive (dead)
[email protected]:~ $ systemctl start nemNode
Failed to start nemNode.service: Access denied
[email protected]:~ $ 

This is what I have in nemNode.service file

[Unit]
Description=nem node
After=multi-user.target

[Service]
Type=idle
ExecStart=/home/pi/nis/package/nix.runNis.sh

[install]
WantedBy=multi-user.target

This is what I tried in .nix.nisRun.sh file

#!/bin/sh
cd /home/pi/nis/package/
./nix.runNish.sh

But this did not work at the cmd line see above.

The original .nix.nisRun.sh file had this:

#!/bin/bash

cd nis
java -Xms512M -Xmx1G -cp ".:./*:../libs/*" org.nem.deploy.CommonStarter
cd -

When I manually enter

cd /home/pi/nis/package

then hit Return, and then type:

./nix.nisRun.sh

The program runs.


#24

well from the output you get i suppose you have problems with setup because
of user / folder ownership.

I do not know how exactly how your PI is configured
but maybe running the script with sudo mode could help.

If you start the script manually it works as you are the owner of the
folder and you have the rights to execute that *.sh script file in your home folder.

systemctl may be running under another user or root so you should maybe check this.

I do not owe a Raspberry Pi so i unfortunately can’t give you the exact solution
as i have configured my node on ubuntu server with init.d.

I hope someone that uses Raspberry Pi could give you more info about this.


#25

absolutely right


#26

greetings community.

How long does node synchronization take, I’ve used nis5_mainnet.h2-1453k.db.zip


#27

Hi…i am a new user here. In my case I am only providing a node at the moment to help verify transactions on the network. I am aware about putting my private key and node name in for harvesting. my nano wallet is run on a different pc.

[prototype pcb assembly china]

admin edit: removed spam link