Transaction in Slow Synchronization of Local NIS

Hi, I have a local NIS synchronizing and one of my system are using it. Let’s say my local NIS is now sync until block height: 2840819 but the main network is already at block height: 2841022. Here is my question, if I did a transfer of mosaic on my local NIS which has a slower synchronization stuck at 2840819, will the transaction not be recorded?

This is because I have a transaction hash return back to me when the transfer of mosaic is successful which is 122f563eeb160be153e581e0183e3dd96c85d1fd978c5c1bf3ff26c6f36ac0f9 but when I search this transaction hash in . There is no such transaction.

I will appreciate if anyone can help on this. Thank you in advance.

FYI: This is an testnet transaction

If your node is in a fork comparing other nodes from network then the transaction will be not reflected.

How can I check whether my local NIS is in a for or not?

If heigh is not progressing at all then I think your node had high CPU uwagę or run out of memory and this caused it.
How much memory you have allocated to node? How your start script looks like (this one where you have xmx and xms params)?

My script code is as below:
pushd nis
java -Xms4096M -Xmx4096M -cp “.;./;…/libs/” org.nem.deploy.CommonStarter

My available ram is 4.7gb so that’s my maximum memory that I can allocate to the node. Now my node height is stopped at 2841961, is this because it had run out of memory? Can this be solved if I add more ram?

To answer the question if it’s out of memory you should have some monitoring on your server. Maybe something can be also read from NIS logs?

I increased my memory to 8gb, but it is still the same, the block is stuck at 2841961. I keep getting this error message in the log:

WARNING Timer SYNC raised exception: org.nem.core.connect.InactivePeerException: Connection refused: no further information
java.util.concurrent.CompletionException: org.nem.core.connect.InactivePeerException: Connection refused: no further information

Here is part of my log file log.pdf (49.6 KB)

<-- UPDATE -->
I found out that my local NIS is communicating to these nodes for synchronization:
bigalice2 -
medalice2 -

All of the nodes above is no longer available and seems like their server is down because I try to get the height from them using and it says the site can’t be reached for all of 3 of them. But when I try “” which is the HugeTestAlice2 node that are online it can return the height result. So my question here is that, can I set my local NIS to communicate with specific node?

After talk on telegram we solved issue:

I think it should fix your issue: Nis testnet sync issue
To speedup syncing you can also use presynced db and replace it in your home dir