Address Book could not be read

Hi all,

I have a wallet and adb file back from the first days of nem.
No private key
No spaces on wallet name
I have tried opening an new account with the same name and password and changing the .wlt files.

and I couldn’t reach the account because of error 123.

Any solutions?


I’m not sure what you want do.

  1. You want open your old wallet because you have tokens?
  2. You want remove old wallet because it’s empty and you want create new empty wallet?


Hi there, thanks for your answer.

1)I want to open my old wallet because I have tokens, yes.

If this is NCC wallet you must open it in NCC. Of course you remember password for this file?

Yeah, I have tried that option.
I downloaded NCC 0.6.92 i guess, and tried to open the wallet, however it says “Address book could not be read” no matter if I try a nonsense password or my correct password.

Did you try this: Nis: address book could not be read?

  1. Backup your .wlt and a.db file in safe place
  2. Remove adb and wlt file (of course you should have backup)
  3. Create a new account in NCC with same name and password. This will create a new wlt and adb file.
  4. Replace new wlt file with old one

Yeah I have tried that and didn’t help

On windows files are stored in C:\Users<user_name>\nem\ncc
Maybe you remove from wrong place?

The place is correct.

I don’t remember if in NCC message is different when you put wrong password or when file is corupted but maybe you put simple wrong password?

@skulldragon If you really forget password I can offer my help. I have some success with this after topic Need help for NEM Wallet forgotten password recovery - Reward offer.