Docker-Compose Up Isn't Recognized


#1

Hi!

I’m now working on this course and the tutorial said to run docker-compose up in the terminal. (See minute 00:47 in the video.)

However, when I ran it in my Windows terminal, it said that docker-compose is not recognized as an internal or external command, operable program or batch file.

How do I get it to work?

Thank you very much! :slight_smile:


#2

Have you installed docker?


#3

@pawelm no I don’t think so. How do I do it?


#4



#5

Okay, thanks @pawelm, I’ll have a look tomorrow morning. :smiley:


#6

Hi @pawelm, I tried installing Docker from Docker Hub and created an account there, but when I installed it failed because it required Windows 10 Pro or Enterprise version 14393 to run.

I updated my Windows PC to see if that helped but it didn’t. What do I do now?

Thanks for your time and trouble.


#7

Here’s a screenshot of it:


#8

You need to install docker with docker toolbox https://docs.docker.com/toolbox/toolbox_install_windows/

Then install docker-compose https://docs.docker.com/compose/install/


#9

@jtey1 I installed Docker with Docker Toolbox but I’m a little confused with how to install docker-compose.

Also in the documentation, does it mean the Windows PowerShell? (Screenshot below.)


#10

Oh. It says that docker compose already comes with the docker toolbox install. So you do not need to install it. Just run a command prompt or powershell and see if you can run docker-compose


#11

:relaxed: Happy Chinese New Year Jonathan!
Outstanding dedication to NEM & LUXTAG :point_up_2:
(It’s a public holiday today in Malaysia)
Rene


#12

@jtey1 does this mean it’s working? :slight_smile:

And happy Chinese new year! :tada:


#13

Yes. :+1:


#14

Thanks @jtey1 for your help and time! :smile: