My local NEM node return wrong result [SOLVED]

Hi all,
I’ve set up a NEM full node, include historical lookup
everything work fine except this api: /account/transfers/[all | incoming | outgoing ]
On my local node, it’s always return the most recent 25 transactions, even hash and id was given, it still return recent 25 transactions
I tried query from other public node and it work fine:

What wrong with my node? which configuration need to be changed? i’ve set nis.transactionHashRetentionTime = -1
Hope for your help

What’s your node ip?
Did you tried use id parameter instead hash? Just add it with last transaction id from previous query.

both hash and id does not work
i deleted /data folder and re-synced yesterday
the node is fully synced now, but the api still return the same result :frowning:

i found the problem
when i query using browser:
my node returns 6 transactions, good boy
buy when i query using CURL, it returns 25 recent transactions :fearful:
what wrong with CURL?

Some characters should be escaped when using curl from terminal but someone already point out this mistake on @nemprojects channel :slight_smile: