My NIS server is not synchronizing, claiming the nodes as blacklisted


#1

My node was running for a while but now I have noticed that it does not sync. My height is shown as 1441300, and the real height is 1441824.

Looking at the logs in the NIS console I see:

2018-01-02 08:45:46.411 INFO skipping refresh of blacklisted node: Node [[c=#86c0e9]hachi[/c] <NBCYZ7REMOHQAASWEUDWE3NV35SU4P4XQOZC7MQQ>] @ [hachi.nem.ninja] (org.nem.peer.services.NodeRefresher a)
......
2018-01-02 08:45:46.418 INFO skipping refresh of blacklisted node: Node [Hi, I am Alice3 <ND6RTQICHTPWUT5OV7SHVDQ42HCVUVRJKJZXDNQA>] @ [62.75.163.236] (org.nem.peer.services.NodeRefresher a)

It is not clear what it means, but I assume that for some reasons the nodes with which the server tries to sync are being blacklisted. Is this right?

If this is the case, why are they blacklisted (I have not modified anything, neither I have added any lines to a config file). How can I make my sever sync again?


#2

It probably means that your node has not enough memory. Are you running it with default setting?


#3

Yes, default settings. No config was modified since the installation. Running on Windows. Machine is pretty powerful and has 32Gb of RAM.

Stopping the server, waiting for a day and restarting it didn’t help. At the beginning the node was updating. But after some time the problem reappeared.


#4

You should modify the start script so that it gives more memory to the NIS. You can learn a lot of troubleshooting tips by following this thread. NEM Supernode Rewards Program


#5

Thank you @Saul. As far as I understood I need to modify nis/config.properties. Do you know which key should I add?

I tried to read the thread, but it is 2k+ messages thread and the find functionality is not really accessible without a lot of scrolling.

Also is there a reason the logs I receive show something absolutely unrelated (kind of hard to guess that skipping refresh of blacklisted node has anything to do with the amount of RAM my default config uses)?


#6

The standalone version comes with the files “nix.runNis.sh” (for linux based systems) and “runNis.bat” (for windows based systems). Inside you can change the parameters -Xms and -Xmx, e.g. use

-Xms2800M -Xmx2800M

for a 4GB node.

That error can appear if the node is not able to communicate correctly with other nodes due to low memory.


#7

Thank you very much. It looks like it works.
Can you please explain what each of these parameters mean? Are they (and maybe some others) documented anywhere (like https://docs.nem.io/en)

Also do you have any idea why the server worked for a pretty long time and out of a sudden started to fail with this message? Is this because now all the blocks do not fit in the memory?


#8

Those parameters are not NIS specific but rather general parameters for Java. First param controls the initial heap size (2800M means 2800 megabyte) and the second one the maximum heap size.

There was more action in the chain, new accounts were created, … All that means that memory requirement is increasing and at some point the original configuration wasn’t enough any more.


#9

Thank you very much for a nice explanation.

Hopefully in the next version, the default parameters will be changed.

Also it would be nice if files like runConsole, runMon, runNcc will be removed. As far as I understood, they are no longer used.


#10

A post was merged into an existing topic: NEM nodes: security protocols


#11