[NanoWallet] Delegated harvesting button not active after I've stopped harvesting [SOLVED]

I am using the NanoWallet and was remote harvesting for quite some time on a Custom Node.

I’ve stopped remote harvesting, as I’ve wanted to update my Custom Node. The node was updated to the most recent version, the block height was updated.

Now when I try to turn back on the remote harvesting the “start delegated harvesting” button is grayed out. It happens even if I select different node.

Any idea why is that?

Is there something under the “Start Deligated Harvesting” button?


You need to enter your wallet-password above the selected node. Further more your selected node must have free harvesting slots available.

If both criterias meet you should be able to click the button to start delegated harvesting :wink:


I’ve typed the password above to reveal my private key, the button is still gray.
There is nothing under my Custom Node. If I select few different nodes I get the: “No free slots on selected node, please choose another”, but when I select some others or mine, I get the gray unactive button, there is no other message stating what might be the problem.

You see the phrase “Enter your wallet password or passphrase” directly above the IP of your selected node? There you have to put in you wallet-password again.

Then the button to start should become enabled.

Furthermore: if you are interested in using a service that provides you the ability to automatically restart your delegated harvesting you should take a look into my nem-tools (NEM-tools.com (automated delegated harvesting, export of transactions and more!))

The service for automated restarting of delegated harvesting isn’t available for public up to now but will be released in this week! :wink:

1 Like

Much appreciated !

There was actually the thin red underline near the password form, however I am having issues spotting the differences with small contrast.
Putting password in resolve the issue, thanks !

I am definitely going to set up my node in a way that it starts automatically.

1 Like