NanoWallet Error on Linux Mint

It’s 64bit linux version?

yeah, it is

Looks like firewall (iptables) problems. Maybe try download and use universal client?

I still can’t import my NCC wallet. When I click on “Import Wallet” and choose my file, nothing happens and it doesn’t appear in the “Select Wallet” list.

Also, I tried building the wallet myself, and this is the error I got:

You have files from NCC? You can’t simple import it into nanowallet.
Please check this thread: Old NCC wlt restore methods.

What I mean is, that I have the .json file that I previously used for my Windows NanoWallet

In nano wallet you should have backedup encrypted .wlt file. In my opinion it should not be file with json… Are you sure you import correct file?

Okay I’ve tried the .wlt file with the same (lack of) effect.

Have you any message or something?
I just create example simple wallet test123.wlt. Please try import this file. Password is test123 (sorry for this service but I can’t upload here .wlt files). If you prefare I can send you email.

Well this is strange. When I try uploading my wallet, it doesn’t do anything, doesn’t even show an error message. Yours works fine.

Hmm. Are you sure it’s .wlt file from nano wallet (not NCC)? Looks strange for me but maybe try import on windows machine with installed NEM wallet.

I exported the .json file from NCC, then my former NanoWallet upgraded it to .wlt, so it can’t be that.

@mizunashi maybe you have idea how fix this problem?

There used to be someone who could not do so by trying to import the Windows 7 wlt file in MacOS.
I successfully imported the Windows 10 wlt file on MacOS.

Because it can not reproduce the case that could not be imported, the cause is now unknown.

How about trying to create it with a secret key wallet?

Right. @Milo_Cider have you also backed up your private key? If yes you can create wallet using this private key.

I’m not sure. When I look at the preview of the .json file I have stored in Google drive, I see a long string of numbers and letters. Could that be the private key?

Private key should have 64 signs or 66 if it starts with 00.

The string of signs I found has 700 signs so that’s probably not it…

I’ve tried it on Windows 7 virtual machine. Didn’t work.