NEM Beta 0.5.11 / 0.5.12 / 0.5.13


#21

using 5.12

doing heavy spamming, stuck at 23055. Here's me log:

http://s000.tinyupload.com/index.php?file_id=36517858547888345842

saw this in log:received block that failed validation: FAILURE_TIMESTAMP_TOO_FAR_IN_FUTURE (org.nem.nis.xn a)


#22

i have 3 nodes that were created from a snapshot(identical in every way except different IP), the snap shot taken of the node that is showing on nembex, and neither of the copies are showing on nembex. (one of them i delete the DB to see how blockchain download goes, its not fully up to date).

i did this when multisig version came out and all three showed on nembex but not now.. is there another way i can check if they are fully accessible to the world/working properly.. they work fine with the client.
i wouldn't trust what you see on nembex, my node hasn't been running for about 16 hrs and it still shows. Plus it says my node is alice2, which it was but then I changed it to abc and at one time it did show up as abc and accessible.

#23

i have 3 nodes that were created from a snapshot(identical in every way except different IP), the snap shot taken of the node that is showing on nembex, and neither of the copies are showing on nembex. (one of them i delete the DB to see how blockchain download goes, its not fully up to date).

i did this when multisig version came out and all three showed on nembex but not now… is there another way i can check if they are fully accessible to the world/working properly… they work fine with the client.


#24

I can't close NCC (0.5.11 Standalone) by menu 'Close Program'. No any reaction. I applied Ctrl+C.


#25

I just tried the installer on Mac.  I was sure I would run into problems but I got it working!  Two things that I noticed, Mac OS wouldn't let me install it because it was from an "unknown publisher".  I went to Settings, then to Security and Privacy, then to I found a little message saying something like, "NEM tried to install but it is from an unknown source and might harm your computer".  I clicked "install anyway" and it really worked.  I am now syncing really fast (I guess that is because there is a node literally a few feet away running on the same router). 

Also, when I went to install I had to click inside of like three folders to get to the install file.  Not a big deal, but it left me confused for a moment.  Lastly, when it finished installing, it was suppose to put an icon on my desktop I think but it didn't.  It did however put an icon in with my other programs so that was good.

After it syncs, I'll test it and see how it works.  :slight_smile:


#26

using 5.12

doing heavy spamming, stuck at 23055. Here's me log:

http://s000.tinyupload.com/index.php?file_id=36517858547888345842

saw this in log:received block that failed validation: FAILURE_TIMESTAMP_TOO_FAR_IN_FUTURE (org.nem.nis.xn a)


Looks like the time synchronization is turned off in your config. At least I cannot see any time synchronization in the log.

#27

Also, when I went to install I had to click inside of like three folders to get to the install file.  Not a big deal, but it left me confused for a moment.  Lastly, when it finished installing, it was suppose to put an icon on my desktop I think but it didn't.  It did however put an icon in with my other programs so that was good.


That option shouldn't show on mac (will fix that). Apple discourages developers from adding an icons programmatically, and leaving that for user.

#28

i have 3 nodes that were created from a snapshot(identical in every way except different IP), the snap shot taken of the node that is showing on nembex, and neither of the copies are showing on nembex. (one of them i delete the DB to see how blockchain download goes, its not fully up to date).

i did this when multisig version came out and all three showed on nembex but not now.. is there another way i can check if they are fully accessible to the world/working properly.. they work fine with the client.


is it different external IP? are you using different boot keys on those nodes? If you have a way of accessing it externally, it's sort of easy to check if it's accessible from outside (using nis api):

http://xx.xx.xx.xx:7890/node/info or http://xx.xx.xx.xx:7890/chain/height


i wouldn't trust what you see on nembex, my node hasn't been running for about 16 hrs and it still shows. Plus it says my node is alice2, which it was but then I changed it to abc and at one time it did show up as abc and accessible.


that one of yours is sort of weird, and it's the only node that does not disappear from nembex...

#29

Mac OS wouldn't let me install it because it was from an "unknown publisher". 


to help anyone else with this problem just right click and click open then it will ass of your sure you want to open

so for me when the installer is done is askes if i want a shortcut and if i want to open the program.  Neither thing happened on my computer.  So i wen into applications and launched the wallet but now neither NIS nor NCC will start.  at the top i just have a grey nem logo and have tried going in and telling it to start ncc and nis but nothing happens


should i be deleting things from when i used webstart?

#30

I running Windows 7 Ultimate 32 bit and Installer don't work because my system is not 64 bit - when Installer will be working in 32 Windows ?

New 0.5.12 Installer also don't work with Windows 32 bit so I make issue on github https://github.com/NewEconomyMovement/NemCommunityClient/issues/280

#31

so for me when the installer is done is askes if i want a shortcut and if i want to open the program.  Neither thing happened on my computer.

That is known and specific to mac, see few posts above

So i wen into applications and launched the wallet but now neither NIS nor NCC will start.  at the top i just have a grey nem logo and have tried going in and telling it to start ncc and nis but nothing happens


Could you provide both NIS and NCC logs? (depends when was the last time you were running webstart, if before 0.5.x than answer is yes, as there was blockchain restart)

#32

It is interesting. I have two accounts that started at 50M with 6.5 score. Now they are both at about 30M. One has a score of 6.6 it and the other has a score of 4.7

They both have spammed out millions.
The only difference is that higher one has more deposits from other people.


What is vested balance on both of them? :)

#33

In nembex many nodes down (like mine). What is causing this?

I managed to synchronize the client, it was with the last synchronized block, but then just down.

Now i try to download blocks from scratch
Here the log of that period.
https://drive.bitcasa.com/send/qE7QAV37W_hl013fKKzggdPSpCCjOQlsNF6UnknG7CYm


#34

When uninstalling the software, the folder C:\Program Files_(x86)\nem-0.5.12\ is correctly removed.
The wallet files remain in the C:\Users<username>\nem\ folder.

A couple ideas for a future uninstall feature:

During the uninstallation, add an alert box showing the location of the wallet files. This will be a helpful reminder.
or
During a complete uninstallation, a dialog box with the option to export then wipe the source wallet files.


#35

all different external IP's.. all in different locations(Chicago, Australia and London). same boot key.


Bootkey is something that identifies node. I'll try to write few words about it somewhere about it, but not today.

#36


i have 3 nodes that were created from a snapshot(identical in every way except different IP), the snap shot taken of the node that is showing on nembex, and neither of the copies are showing on nembex. (one of them i delete the DB to see how blockchain download goes, its not fully up to date).

i did this when multisig version came out and all three showed on nembex but not now.. is there another way i can check if they are fully accessible to the world/working properly.. they work fine with the client.


is it different external IP? are you using different boot keys on those nodes? If you have a way of accessing it externally, it's sort of easy to check if it's accessible from outside (using nis api):

http://xx.xx.xx.xx:7890/node/info or http://xx.xx.xx.xx:7890/chain/height




now all three were showing for a while, and one seems to have dropped down into the red.. dont know why.. they all seem to function fine with NCC.. (although they do go offline periodically for a short period)

all different external IP's.. all in different locations(Chicago, Australia and London). same boot key.

#37


all different external IP's.. all in different locations(Chicago, Australia and London). same boot key.


Bootkey is something that identifies node. I'll try to write few words about it somewhere about it, but not today.


ok.. always great to hear about the hows and whys of the technical stuff. :) 

so best to use a different boot key per node?

#38

Since upgrading to NIS / NCC I am getting an error on the NCC client when logging in

My setup
NIS - Centos 0.5.11
NCC - Windows 8.1, IE 11, fully patched (also tried with Firefox on same machine and same issue)

KC


#39

In nembex many nodes down (like mine). What is causing this?

I managed to synchronize the client, it was with the last synchronized block, but then just down.

Now i try to download blocks from scratch
Here the log of that period.
https://drive.bitcasa.com/send/qE7QAV37W_hl013fKKzggdPSpCCjOQlsNF6UnknG7CYm


Hi Icharles123,

I checked the log and your node did not survive the spamming last night.
The current version puts high cpu load on the nodes while serious spamming is in progress. Therefore nodes eventually die during those spam phases.
The next version, which will be out either today or tomorrow, will solve that problem.

Bloody Rookie

#40


In nembex many nodes down (like mine). What is causing this?

I managed to synchronize the client, it was with the last synchronized block, but then just down.

Now i try to download blocks from scratch
Here the log of that period.
https://drive.bitcasa.com/send/qE7QAV37W_hl013fKKzggdPSpCCjOQlsNF6UnknG7CYm


Hi Icharles123,

I checked the log and your node did not survive the spamming last night.
The current version puts high cpu load on the nodes while serious spamming is in progress. Therefore nodes eventually die during those spam phases.
The next version, which will be out either today or tomorrow, will solve that problem.

Bloody Rookie
Ok, good work!
I see the antispam works well although I do not spamming the network very often, 10s btween txs.