NEM Beta 0.6.72 + 0.6.73


#21

.

IMPORTANT NOTICE

As mentioned, lightwallet does all the signing inside the browser, however you should only use lightwallet on node YOU OWN, or node YOU TRUST. The reason is one could create EVIL lightwallet, that would steal your keys, or serve totally FAKE lightwallet

We WILL provide a way to start lightwallet locally and connect to a selected node (similar like in ncc)


Lightwallet STANDALONE 1.1 + 1.2
#22

Docker config updated to use latest version:
These are the scripts if you want to build the docker image locally yourself:


However, images a available from docker hub:
https://hub.docker.com/u/rb2nem/

I encourage you to test it out and let me know of any failure (or success). I find it the easiest way to run NEM server or client.


#23

i have problem with gpg signature.
gpg --verify nis-ncc-0.6.72.tgz.sig nis-ncc-0.6.72.tgz
results in:

gpg: Signature made Wed 30 Dec 2015 02:59:58 PM CET using DSA key ID A46494A9
gpg: Can’t check signature: public key not found

How can I verify nis-ncc-0.6.72.tgz?


#24

You need to import the public gpg signing key:

gpg --keyserver keys.gnupg.net --recv-key A46494A9

The nem docker mentioned earlier does it for you if you run docker :wink:


#25

These update decreases memory usage by ~100MB. :grinning:

[quote=“filchef, post:17, topic:1706, full:true”]
please give the list of nodes on testnet
[/quote]http://bob.nem.ninja:8765/#/nodes/


#26

We WILL provide a way to start lightwallet locally and connect to a selected node (similar like in ncc)

As promised, here it goes, have fun!


#27

Hello friends, I am an older fellow who is trying to navigate the crypto world and wonder if someone might be able to help me. I am impressed with NEM and have successfully updated wallet releases from nemwallet-0.6.28 through nemwallet-0.6.31 using the Windows installer. Recently I installed the nemwallet-0.6.72 release and it seemed to go smoothly with NCC and NIS running but it didn’t open to the password page. (blank). I recently installed the nemwallet-0.6.73 release and still the page is blank although NCC and NIS is running. At this time I can’t open my nemwallet. I have tried to do another installation with no luck and have not uninstalled any NEM software. I appreciate and suggestions you can give me.


#28

I cant click in New Namespace or New Mosaic.
This is a bug or they are not fully implemented?


#29

the latter


#30

I had the very same error in the standalone when updating from .43 to .72. This error was fixed with release of 0.6.73.
What browser are you using? Is all of the page just white?

Can you check if there is an error appearant? For Firefox atleast, just click Tools - web developer - web console.

If there is an error please post here what it tells you.

If nothing helps:
Save your config properties file from the Nem package folder. There is one in NIS and one in NCC folder. Delete the NEM package folder. Make a fresh clean install of NEM. Put the Config properties data back into the folder.
But it is just neccesary if you have custom settings, like auto harvest, autoboot etc.

Remember it is mandatory to have a backup of the:
a) Nemwallet
and
b) Private key

Alternatively you can try out the standalone. There you just need to import a private key/or create a new wallet. Then you just need to connect to a trusted node.


#31

Make a backup of your wallet. If you have your priv-key stored elsewhere securly that is fine as well but make sure you’re able to re-create your account.

Uninstall the client.

Delete the whole NEM folder. If you had special configs you’ll lose them but one of those configs might be the thing that’s causing the issue so you should get rid of them.

Install the latest version and see if it works now.


#32

If that doesn’t work, you could fall back to the stand alone. The installer has been giving a lot of people problems, even me, but the stand alone works fine.


#33

This is what you really need to worry about. Save the files *.wlt and *.adb. Rest you can delete and do what you want with it.

My suggestion is to do this, always fail safe. Just copy the entire standalone to a directory in C drive for example. Name it NickelNEM673

Then go into the directory and just run mon.bat. It should fire up just like that.

Now, the data directory is in yourusername\NEM. Just make sure that you copy your *.wlt and *.adb to yourusername\NEM\NCC.

If that doesn’t work, delete the accounts_cache_mainnet.json file in the yourusername\NEM\NCC directory. If that still doesn’t work, delete the file ncc.cfg in the yourusername\NEM\NCC directory.

If that still doesn’t work, delete the above two files and delete the NIS directory in the yourusername\NEM\ directory.

Run mon.bat again and you should see synchronising activities happening and the client should fire up nicely


#34

@patmast3r @rockethead @Brainofmasses

Many thanks for your help. I’m sure that I will have my wallet up and running soon.


#35

cool! thank you


#36

Update: Today I launched my NEM wallet after an absence of a few days. As I had mentioned to you, I had earlier installed the nemwallet-0.6.72 release and then the nemwallet-0.6.73 release in hopes that the NEM community client would appear and allow me to open my wallet.
The good news is that the community client page opened today and immediately started to load blocks and fully synchronize after I booted a local node. The client info shows that I have the nemwallet-0.6.73 Beta version. So, I guess that I performed the correct installation procedure but it took awhile for the process to happen. Sometimes patience is a virtue.
Many thanks for taking the time to help me.


#38

00ee6b925e8a4ca9e425617ef95a24b21522767bb65a8b902731c8b44885bd56f1

Done


#39

Great! thanks very much


#40

New Release: NEM Beta 0.6.75, 0.6.77 + Lightwallet STANDALONE 1.8
Topic locked.


#41