Nem/trezor bridge

I’m not a techie but I followed the directions to install the Nem wallet on my Trezor. the NEM icon is on my Trezor wallet but when I try to access it is keeps asking me to download again. What should I do?

I had similar issue, I downloaded the bridge and it works fine now. You get it on the trezor website. It was a bit of a search

Did you download the Universal client with Trezor support?

I’ve tried everything. The install went fine, and the Nem icon is present on my Trezor wallet. I just can’t access my Nem wallet on Trezor, I just get a screen with a link to the download again… I’m stumped, guess I’ll just leave my coins on the exchange for now.

I don’t know what NEM icon on wallet you are talking about! ?

My Trezor does not have Nem icon, so this is alarming to me. I want to make sure you were not scammed somehow.
Please give me detailed list of instructions you followed. Where did you get your Trezor?

I had a similar issue, and the bridge worked for me. Now When I plug it in I get the window to export wallet instead of go to Trezor to download bridge pop up I had gotten before I downloaded the bridge.

Did you download the universal client with Trezor support and the Bridge on the link I gave above?

I think that important question is what Trezor version both of you are using.
I know there is some problem with bridge on new Trezor T.

I am using a Trezor that I ordered new from the Trezor store. Running firmware 1.6.0. I downloaded the Nem NanoWallet using these procedures:

  1. Downloaded Nano Wallet v2,0.14 (I have Windows 7 & Chrome)
  2. the Universal Client
  3. Extracted the zip file and started the app on the web-page.
  4. Clicked on LogIn , next window selected Login with Trezor, confirmed Mainnet selection, hit next.
  5. Confirmed NEM address Export, unlocked my Trezor.
  6. Trezor showed NEM address for my account. #1. Confirmed on the Trezor, received Welcome to your NEM Wallet msg.
  1. NanoWallet displayed., Clicked Account button to get account info page.Address shown verified on Trezor, so should be fine. I copied the page with the address.

Public Key: says I need to make a transaction to get a public key.Had to log off at that point, thinking I could come back later to transfer my XEM into my Trezor Nano Wallet. But…

Now when I log on to my Trezor, and try to access the Nano Wallet, all I get is the Nano Icon, with message that says I need to download the wallet. Hope that’s enough info to get an answer. Maybe I missed a step.

Thanks, Dixie

Sorry, forgot to tell you that I’m not using the Trezor T. And when I say Icon, I just mean that the Nem button is listed with my other coins such as Dash, Ether, etc on the Trezor menu. Dixie-G

@Dixie_G many users reported that integration don’t work with Trezor T. One user mentioned that Trezor is fixing it.

@Dixie_G Seems like you did everything right from my point of view. My Trezor is older so there might be the difference. But setting it up is not as plug and play as I think it should be. As pawelm notes sounds like they are fixing this on Trezor side.

I can’t open the downloaded zip file for the Universal Client wallet. All that happens when I click on open is that I get a string of letters at the top of my screen.

You should extract zip file. If Windows right click on zip file and Extract + define location where it should be extracted.