NEM Wallet Beta 2.4.2 - Bug bounty paid in XEM


#226

You can deactivate delegated harvesting in Nano Wallet, the supplied public key is ignored because NIS knows which account is the delegated account.
If you auto harvest on your supernode, Nano wallet can only see the correct harvesting status if you are connected to your supernode, i.e. you have chosen your supernode with the node selection popup. At least that is my understanding of nano wallet.

I don’t know, @quantum_mechanics, can you please answer that question?


#227

I asked this because i see in Nano Wallet that the
the Harvesting status is set to INACTIVE for the remote delegate account even if i’m connected to my supernode where the harvesting is active and i see
in NCC is set to active and i can deactivate it there
but in Nano i can only activate because it seems is not aware that is active.


#228

Hmm…maybe Nano always expects the delegated account that is displayed in Nano to be the real delegated account.
Again, this is a question for the Nano Wallet coder @Quantum_Mechanics.


#229

Regarding the 2nd question i figured out that if i import the wallet that i have backed up from the NanoWallet and not the one that is saved the 1st time before login that it doesn’t akst for the upgrade.

Also i suppose the address book is not yet implemented in the NanoWallet
i can’t see there any adressess that I had in NCC.


#230

Hi,

It is a bug (https://github.com/NemProject/NanoWallet/issues/175)

The old remote must be deactivated and the new one in Nano must then be activated.

Once it is done you must change the old keys in your supernode for the new delegated private key:

  • nis-ncc/config-user.properties
  • supernode-servant/config-user.properties

Then finally enroll your node again to the node reward program with the new delegated public key, @BloodyRookie will deactivate the old entry.

Yes it does not support import of NCC address book yet


#231

Thank you very much.
I will then proceed as you instructed here.


#232

I’m trying to migrate my wallet from NCC into NanoWallet. Everything with exporting of json file and importing into Nano login screen is clear, but when I put password and click into “Upgrade wallet”, it looks nothing happened (I’m just waiting more than 30 minutes, it couldn’t be so long, isn’t ? ).
I’m trying this process in Chromium (could it be the same as Chrome in this way?) 59, OS Fedora Linux. Any hints ? Thanks.


#233

Hi,

No it should take only 1 or 2s, I just tried on Chrome and it worked.

How many accounts do you have in the wallet ?

If you only have one account to import you can simply get the account private key from NCC and create a private key wallet with it in Nano.


#234

Just one account (with delegated harvesting into my NIS node…anyway, I’ll have to change delegate harvesting due to new public key, is it correct?). Now I’ trying the same upgrade process in FF 55 … same issue, means nothing happened after “Upgrade wallet” button click, for a long time. It’s really weird…


#235

PS: I’m running Nano thru my local Apache, with normal http (80/tcp) port (it could be secure as it is a strictly local connection) … is this the correct way ? I saw there is also Linux desktop Nano app, but even of that, I prefer browser/web access…
PS2: all the previous versions of NCC worked in my browsers (FF, Chromium, Chrome, everything under Linux) without any troubles.


#236

I’ve been tested this issue on another computer (also Linux based), under FF, Chromium and Chrome as well. Same issue in every cases (successful import of *.json file from NCC, then nothing happened after “Upgrade wallet” click). Really strange…


#237

Yes if you were harvesting in NCC you need to deactivate the old remote:

Services -> Manage delegated account -> Use custom key -> Paste your old delegated public key -> Select deactivate -> Send

6 hours later you can go back to Manage delegated account page and just send an activation transaction to activate your new remote (the one shown in the grey input)

Then if harvesting was linked to a supernode you need to update the key in the NIS, enroll again with the new delegated public key and ask @BloodyRookie to deactivate the old entry here: NEM Supernode Rewards Program

Should be secure but you don’t need any local server to run Nano

Okay, strange indeed, it works here… Will look into it for v2.0


#238

if you have more than one account how I can import all my accounts at nano wallet???
Hi,

KloNEM:
I’m just waiting more than 30 minutes, it couldn’t be so long, isn’t ?
No it should take only 1 or 2s, I just tried on Chrome and it worked.

How many accounts do you have in the wallet ?

If you only have one account to import you can simply get the account private key from NCC and create a private key wallet with it in Nano.


#239

Ok, thanks, I’ll do it thru this way…

Ok, but if I don’t want (or don’t need) to run linux NanoClient and just use the html pages and *.js, probably I’ll need local webserver (e.g. Apache), is that correct? I’m thinking, if there couldn’t be a trouble, if sign-up/login doesn’t expect app hearing on some appropriate port (?)

What is more strange - I’ve been tried another way - in Nano “Sign Up”, then “Private key wallet”, then put my private key, name of wallet, pass, etc., finally clicked on “Create private key wallet”, and voilla - nothing happened. Looks like the same issue as with importing wallet (*.json) from NCC, so I’m observing (see above), if there couldn’t be some “global problem” with expecting of some another port (than default 80/tcp Apache’s one), or something like this ?


#240

Version 1.4.10

  • New fee structure on Mainnet
  • Added passphrase strength estimator to brain wallet: https://github.com/dropbox/zxcvbn
  • Brain wallet passphrase requires 40 characters minimum
  • Moved purge button into footer
  • Show an alert asking to change node if not connected within 5 seconds after login
  • Show an alert if user’s brain wallet seems weak (< 40 characters)
  • Minor fixes and improvements

#242

@jelin1984 You can try to follow this https://blog.nem.io/ncc-to-nanowallet-export/. Upgrade works for me, should work for you too.

@KloNEM No need for a local webserver, you can click on start.html and it will open in your browser. Everything is client side, it does not expect any port or else for creating wallets.

Are you using latest version ? Can you open the browser console, try to create a private key wallet and look if you see any red error message.

Don’t paste console content here, send it to me via PM.


#243

kindly remind :slight_smile:


#244

Hi Team. @Saul
The download page is still ver1.4.3.
Please update to the current latest.

https://nem.io/install.html


#245

Eh, my fault! I really don’t know, why I was expected, that Nano has to be running over TCP/IP / webserver, and not just “as local files”. So, I did it by this way, click on “Upgrade wallet” and everything is running smoothly and fine now. Thanks and sorry again!

Just a question - also in this case (“Upgrade JSON/existing NCC wallet”) I have to deactivate delegated harvesting in old NCC and (after 6 hours) just do activation in “Manage delegated account” in Nano ?


#246

There is now a 5,000 XEM bounty for issues reported to QM’s Github.

Any bounties for bugs in the Android wallet?