Node setup issue using docker


I tried setting up the new node. For that, I tried this, sudo docker run -v $PWD:/home/nem/nem -p 7890:7890 rb2nem/nis by pulling the docker image given here.

But I’m getting one error i.e., something really bad happened: java.util.concurrent.CompletionException: java.lang.IllegalStateException: network boot failed (org.nem.nis.NisMain b)

Can anyone help me with this? Is this because of the port issue? or the firewall issue?

I can see 3 files - nis, nis-stderr.log, nis-stdout.log, and inside nis, data and logs folder.

Can anyone tell me where the peers file is present?

If you can, you should probably use those scripts: GitHub - rb2nem/nem-docker: Docker configuration and scripts to run NEM software
If you can’t use them, you can probably find information in there to get it running.

Let me know how it goes

PS: Just to be sure there’s no confusion, this is for running a NEM node, note a Symbol node :slight_smile:

Thanks for your response. I’ll give a try and let you know


Does it require the installation of any other pre-requisites to make it run? or it will install automatically?