Old NCC wlt restore methods

What do you think?

I cannot say, it could be a problem in NCC wallet export maybe. From here all I can say is that if password is 100% correct then the private key inside the wallet.json is corrupted.

The alert Password is not valid appears if app cannot decrypt the private key or if the private key decrypted does not match the address of the associated account in the wallet.


Does anyone get an answer about this problem?

Passwords specified in NCC only recognize the first 128 characters.
NanoWallet does not have that limit.
For the reasons above, when entering a password with NanoWallet, you can login by entering the first 128 characters of the password.


I am having the same problem as FLASH and have downloaded the new version of NCC but now I am having trouble getting NCC to run. It seems to try and run, but closes immediately after opening. Would appreciate any suggestions!

I think that the downloaded file is nis-0.6.93.tgz file name.
If it is the previous version, it is nis-ncc-0.6.91.tgz.

From the latest version, NCC has been discontinued. Please migrate to NanoWallet.

For information on how to migrate from NCC to NanoWallet, please click here.

If you do not have an older version of NCC, you can not migrate, so please download the old version from the following location.


For details on how to use NanoWallet please see here.


I’m in pretty much the same boat as Flash: I have the old .wlt and .adb files (and the password) for the wallet from an old NCC client. When I try to open the .wlt file in the nano wallet (select “Import Wallet”, navigate to .wlt file and select it), i’m dropped back on the “Already a NEMber?” screen, but the wallet doesn’t show up in the list and there’s no error message.

I’ve also got the original NCC 0.6.26 software I originally created it with and a copy of the latest NCC that was linked above in this thread, but neither seems to recognize the .wlt file. Is there a way to explicitly get the old NCC client to open the .wlt file so I can perform the export steps with it?

You can download and install the last NCC version which you can download from here:

Before you do this make copy of the *.wlt file and you password.

Then after you install NCC open your wallet file with it.
Then once you are in the NCC you have 2 options
export the wallet for lightweight wallet
export the private key.

If you choose the 1st option then you can later import the exported wallet *.wlt file into NanoWallet
or if you choose the 2nd option
then you can create a wallet from private key in Nano Wallet.

1 Like

I have downloaded the 0.6.91 file and also having issues connecting to NCC. It says NIS is running and the blocks are up to date, but I can’t reach the old login page i use to go to. I tried to load my .wlt file to the Nanowallet but it wouldn’t take. Is there a certain web address link or something i need to do so I can access the old login page? I understand the options to transfer over once I get there, but I can’t even get to the login page right now?

Also I use to click open NCC in browser and it would take me right there, but not anymore, FYI.

Was able to get to the wallet following this method. Hope this helps others.

"Sometimes people update and they have a problem with NCC starting. If that is so then do the following:

Delete the file accounts_cache_mainnet.json in the folder c:\users\ < your_user > \nem\ncc."

Then start ncc again.

1 Like

Thank you your advice.

Your Welcome. I had a heck of a time fixing this. Just needed to do that ONE thing!

1 Like

This is the part I’m unclear on. I have the NCC client up and running (I can get both the original one I created the wallet with running, or the latest version before discontinued).
I just can’t figure out how to get it to see the files. They don’t show up in the UI of existing wallets and I don’t see a way of letting me browse the file system to point it to them.

Then you need to find the where nis / ncc is installed.
On linux systems that is usally in $HOME/nem/

find the ncc directory and paste your *.wlt file there
in that case in $HOME/nem/ncc/

If you are on windows try to do the following:
go to start -> run then type there %appdata%/nem
this should open the folder where nem is installed and then find the ncc direcory and paste the
wallet file in it.

Then try to restart the ncc and reopen it in the browser.
You should then have the wallet in the list of the wallets and should be able to open it by entering your password.

Dependign on your windows version it could be that nem data folder is stored somehwre in this locations:

C:\Users<your user name>\AppData\Local
C:\Users<your user name>\AppData\Roaming
C:\Users<your user name>\AppData\LocalLow\

Let me know if this helped.



Thank you for your continued assistance!
I have the NCC code installed on my E drive, I cannot find any reference to nem in any of the 3 AppData folders (on C:\ or on E:), so I’m assuming it should all be self contained in the root folder (https://imgur.com/dqpAg3v) .

I have the .wlt and .adb files in the nem/ncc folder, but even after restart, the client does not see that wallet. However, it does see a different (empty) wallet that I created later. What’s interesting is that I cannot find any files that correspond to the new wallet that it does see. Even if I remove all .wlt and .adb files from the ncc folder and restart, it still sees the new wallet. Doesn’t that imply that the client is looking for the wallet file elsewhere?

I’m actually a developer, so I can get pretty down and dirty with the source code if need be. I’ve checked out the NCC project from github and reverted it to the version that I have installed so I can try to trace how the .wlt is generated and maybe try to reverse engineer the process, but it’s taking some time. If you can point me in the right direction or any other advice, I would greatly appreciate it!


Please seach disk for all wlt files (if you dont try this already). Probably new wallet is in different directory.

Hey, I managed to get into the wallet! I found the other place that nem was storing the wallet it did see and put my old files there. The password worked and I’m in. I recall that on the day I first set it up and received a transaction, I created a second wallet after the first failed somehow.

Sadly, it looks like the files I have are for the second, empty wallet, so I think all hope is lost for me recovering my initial stake as I cannot find any trace of the original wallet. In my panic to try to recover access to it initially, I created another wallet locally with the same name through NCC and I’m thinking it’s possible the old version of the client overwrote the original one’s files. :cry:

Thanks for the help anyway everyone!

If anyone wants to send some pity NEM my way, I would be very grateful for the consolation. I’m just coming to terms with the reality that I just cost myself half a million dollars…

Ouch… this is sad. Maybe you can find your wallet and then send all from this topic tip :wink:
Good luck anyway. Half a million dollars is a big loss… Search for backups! Maybe you have one.

If you try in NCC create wallet with existing name NCC don’t let you this (error is produced). It shouldn’t be possible.
If you really overwrite wallet try some recovery data program.

1 Like