Servant file running


#6

yes, servant is mandatory.
servant.sh looks similar to this?

java -Xms256M -Xmx256M -cp “.:jars/*” org.nem.rewards.servant.NodeRewardsServant


#7

@BloodyRookie
Yes, except the memory is limited to 128M as below:

java -Xms128M -Xmx128M -cp “.:jars/*” org.nem.rewards.servant.NodeRewardsServant


#8

how do you start the servant.sh script? Are you in the /root/nis-ncc/package/supernode-servant/servant folder when starting it?


#9

@BloodyRookie

Hi yes, I am in that folder.

I run it as ./servantStart.sh


#10

kind of out of ideas :confused:
how many jars does the jars folder contains?


#11

I could re-build the server, I tried it with Pauls tutorial on Debian, and I had issues with the nis service starting, then I trashed it, and tried it on ubuntu with a mixture of the ubuntu tutorial and Paul’s tutorial. The NIS is working now, but the servant doesn’t seem to start up. Is the tutorial on NEM Supernode Rewards Program one that works OK, I noticed some things are done differently than Pauls or the Ubuntu tutorial


#12

the issue is not related to the OS i think.
Asking again, how many jars are in the jars folder?


#13

There’s 41 jars in the jars folder.

Probably not related but which of the config.properties or config-user.properties should have my delegated private key details etc within them?

/root/nis-ncc/package/supernode-servant/servant/config.properties
/root/nis-ncc/package/mon/config.properties
/root/nis-ncc/package/nis/config.properties
/root/nis-ncc/package/ncc/config.properties

/root/nis-ncc/package/supernode-servant/config-user.properties
/root/nis-ncc/config-user.properties


#14

I think the problem could be related to me having the private key and IP address in both:

/root/nis-ncc/package/supernode-servant/servant/config.properties

and also in

/root/nis-ncc/package/supernode-servant/config-user.properties

I think either one or the other should have the entries for del. priv. key and IP of supernode in there, I could be wrong


#15

no that didn’t make a difference after changing back to 127.0.0.1 and # out my entry. So left back to as is. Going back to your original question, there are 41 jars as per my response earlier.


#16

41 is the correct number of jars.
Somehow java doesn’t see the servant jar.
This has nothing to do with the configuration files. You need to have the delegated private key in the servant config and nis config. If there is a config-user then it has to in there too.


#17

thanks BloodyRookie, I think we may have got it working. I checked all the config.properties and config-user.properties to make sure they all contain del priv key and IPs. Then I copied the servantStart.sh from the servant folder into the supernode-servant folder where the config-user.properties was located, and the servant seems to have started. Fingers crossed. Many thanks for your guidance and help. I’ll keep monitoring it.


#18

um…but that means the jars folder is in the supernode-servant folder as well? else jar would be relative to the startservant.sh in /servant/jars.
Anyway, glad it worked.


#19

This is what I see when I started: wondering if it is as it should be in a normally functioning supernode?

INFO Node rewards org.nem.rewards.servant is ready to serve. (org.nem.rewards.servant.NodeRewardsServant startServer)

On another putty session I have the nis running, and noticed a lot of "Account Nxxxx-… is not yet allowed to generate a block. is this normal?

Accessing 7890 on browser seems ok, info and extended info
Port 7778 on a browser shows: {“timeStamp”:46467805,“error”:“Not Found”,“message”:null,“status”:404}
When opening a browser to http://52.209.222.196:7880/ I see a 404 error
Problem accessing /. Reason:
Not Found
Is the above normal functioning?


#20

Those are the two links that should work if everything is ok (assuming the ip is correct):

52.209.222.196:7890/node/info
52.209.222.196:7880/nr/metaData

none of them are actually working. Is this a vps or a node at home?


#21

@BloodyRookie, it’s a VPS on AWS.


#22

seems nis is not running


#23

just restarting it now


#24

This one now works.
http://52.209.222.196:7880/nr/metaData
I’m just trying to find a way to get this nis working, will keep working at it.


#25

Weird. After I # out the private key and IP entry in the config.properties folder in the nis folder it seems to run the nisStart.sh script fine and nis service starts up. I think it could be related to the path in the nisStart.sh file, somehow linking to either the config.properties or config-user.properties files.

Oh well, it’s starting, lets see how long it lasts! :slight_smile: