[SOLVED] Chain height not increase

Hi guys, my node chain height is not increasing, is stoped in 2552832.

“metaData”: {
“features”: 1, “application”: null, “networkId”: -104, “version”: “0.6.97-BETA”, “platform”: “Oracle Corporation (1.8.0_241) on Linux”

Any idea?


Hi. How your start script looks like?


cd nis
java -Xms512M -Xmx1G -cp “.:./:…/libs/” org.nem.deploy.CommonStarter
cd -

1gb is not enough to right now for running regular node. Please try increase Xmx at least to 2.5G

I updated the max memory for java usage, but i cannot obtain blocks greater then

“height”: 2552832

at this moment i have 97GB of Blockhain, with only 40% disk usage.

anyway i am managing to generate transactions, it happens that i cannot query the hash of this transaction, example:



Your node is at fork. You should remove blockchain db (/nem/nis/data) and sync from scratch or use db with presynced blocks (it will speed up process) https://bob.nem.ninja/nis5_mainnet.h2-2520k.db.zip

Ok, i have 2 nodes, the first one is using testnet, that node is not syncing. I did it in testnet node, syncing.

The mainnet node is syncing:

“height”: 1941611

Just for the record (I am not sure if the problem was solved meanwhile): I ran into the same problem, my testnet node got stuck at some block height. This happened after I set a user friendly name using vi editor in command line.

It turned out that others had the problem to:


Greg answered that bug report, apparently it was that my editor had different line style ending than the bootstrap repo:

This is your Operating System being configured with different line endings than the bootstrap service repository.

You can configure VIM to use the same line endings.

If you still encounter problems after adapting your editor, feel free to re-open this issue

After using nano instead of vi the node was syncing again. Maybe others also encounter that problem, thus I answered here.

1 Like

@Urk_Raider this was question about NIS1 node (not Symbol).
@alexjavabraz as I understand problem is fixed or you have still some issues?

Fixed, my node is synced! Tks.

1 Like