Wallet Does Not Connect To Nodes

Hi,

have just installed the latest NanoWallet-2.3.2-linux64 on Linux Ubuntu 18.

I was able to create a wallet key and login ok, but the Node indicator on the upper right is always red.

I’ve tried selecting different nodes but no difference.

I have checked other threads about this problem but haven’t found a solution.

Does anyone know which ports the wallet uses for node connections?

I do not have access to the router here in my building, it is a communal wifi router. Most of the ports are closed, with exception of 80 and 443.

Thanks in advance!

Hello. Wallet is using following ports to connect with nodes:

  • 7890 - API
  • 7778 - Websockets

Both should be open

Hi CryptoBeliever,

well it does appear to be syncing at last, if I have understood correct…?

the indicator is on green.

Block height: 2853354
Current node: http://nijuichi.nem.ninja

Thing is the wallet is still stuck on this block 2853354 and I see from the explorer at explorer.nemtool.com/#/blocklist that it is now at [2853584] The wallet keeps saying “error occurred at network fetching time”

The indicator is on green.

I transferred a small amount of NEM to test, and it shows up on the explorer.nemtool.com for my NEM address - but it is not in my wallet, wallet says zero XEM and it is still on block 2853354.

So something is still not working correctly. Or maybe NEM takes a really long long time to sync? I left it syncing during the afternoon, but it is still stuck…

Try changing node to other. For example http://hugealice.nem.ninja/. Maybe node you mention had some temporarily syncing problems.
Desktop wallet you are using is light wallet. So it uses external nodes to fetch network information.

Well I am trying hugalice.nem.ninja right now. Indicator is red.

Yesterday evening it finally showed my 9 NEM test transaction.

I then sent another transaction to test, this time 50 NEM. But this hasnt appeared in the wallet.

This morning it was still showing just 9 NEM. Indicator green.

So I started the wallet new.

Since then there is nothing, indicator red, block: 0

it does not show my 9 NEM nor my 50 NEM.

I know they were transferred because I saw them on the blockchain explorer.

If NEM does not work and there is all this trouble right from the start, then it does not look good.

All this should be taken care of by the wallet automatically behind the scenes, without the user having to mess around.

The money is not in my wallet, so I cannot access it. It is currently in no-mans land! Not good. Thank goodness I had the sense to just send small test sum first and not a large amount, else it would really be a disaster.

If it does not improve then I will forget about NEM, sell my coins and replace with another project. I cannot use a coin if the wallet does not show my deposits!

NEM doesnt start from now but it’s working stable from 5 years.

I think it’s problem on your end with connection (either firewall on router or computer is blocking). I don’t have any issue now connecting to hugealice nodes (http://nijuichi.nem.ninja also works without issue). And I’m also using Linux (Mint).

It’s possible to try with other Internet connection source and/or on other device?

You can also upgrade to latest version (2.4.7)

Instruction:

  1. Extract zip archive.
  2. Open folder where archive was extracted.
  3. Run start.html in your browser.

If your computer will block connection there should be also visible errors in Chrome console (Console or Network tab).

OK well I will try the newer version. At the moment I am using Version: 2.3.2

There is also the Exodus wallet which I have installed. Perhaps that would perform better?

I now see my nanowallet is finally displaying both of my deposit transactions. But they were done yesterday afternoon and evening. It should not take 12 hours to display!

Does the wallet download the entire NEM blockchain ? ?

No. Wallet is presenting data directly from node. That’s why it works instant (if there is no connection issues).

You can try Exodus. It’s using own nodes but maybe connection goes via some Proxy/API Gateway Exodus providing (for example on another port) so maybe you will not experiancing connectivity problems.

Well I have just transferred some NEM to my Exodus wallet and it was done in seconds with no problems, no delays, no errors, no node issues.

I am now trying to transfer the test NEM I sent to the Nanowallet to my Exodus wallet - but the Nanowallet is not responding, the “send” button is shadowed out. I have entered my password. The node indicator is green but I get a red message popping up saying “an error occurred at network fetching time” !

I do not want to use this Nanowallet anymore.

I am importing the Nanowallet private key into my Exodus wallet, this should be performing the transfer now.

Pity there are these problems with the Nanowallet.

Update: funds have now transferred to Exodus. No more Nanowallet!

I’m still thinking you have connection issues because your firewall/config on computer/router (I would prefer to know why) but if Exodus works for you then OK.

Well I dont have any firewall on my computer. All disabled.

The router may be the limitation.

But Exodus works fine.

1 Like

Here’s my take in this about the latest NEM wallet. I live in Australia and use the Coinspot exchange.
I downloaded the NEM wallet with the link in the client to install the latest version (2.4.7), but first this is a real experiment I did yesterday.

I sent 50 XEM to my NEM wallet through Coinspot. They have a 4 XEM mining fee. This means 50 XEM is sent to our new NEM wallet, but a further 4 XEM is taken away from our Coinspot wallet.

The next experiment was to return our XEM to our Coinspot wallet. The NEM wallet has a 0.1 XEM fee. Hence, we are returned a total of 49.9 XEM into our Coinspot wallet. Both ways we lose XEM.

I am now using the latest installation that uses the browser (Chrome for instance). Everything seems to be working with a green node. May send my XEM to the new NEM wallet when it gets closer to the snapshot in December, 2020. Opt-in for Symbol tokens (XYM) should be available now.

@sherwinjtb have you some question/problem or you just sharing your experiance? :slight_smile:
Regarding fees. 4xem is withdraw fee taken by coinspot and 0.1xem is network fee to do tx (probably you added also message required by exchange).

@CryptoBeliever Hi.
I would assume most exchanges have their own protocols, but yes there’s a message to be included (more like a reference number).
Tried sending XEM back to Coinspot again.
You need information such as Receiving address, hash code, etc.

Just make sure to read the instructions carefully before hitting the confirm/submit buttons.
Takes a few seconds or possibly minutes for transactions to complete.

Also tried joining the community hub, but don’t really have the time to commit right now.
Apparently we need to stake 1000 XEM tokens. Kind of stopped there when I couldn’t figure it out after a few minutes.