XEM assets not shown after restoration

I had not visited my NEM account (MacOS) for some time, but when I did no XEM was shown in the balance. I loaded a newer version and restored the account with the primary private key. Still no joy as the account balance was still zero. Where did my XEM go and how can I recover these assets? Please help. Thanks

First check your balance in explorer -> http://explorer.nemtool.com/
If it’s correct then please verify that your node you are connected is OK. It should be green circle in top right corner.

I clicked the indicated link and don’t see how to check my balance as it shows a number of addresses but not mine. Please tell me how do I use this link to check my balance? Thanks.

Put your address in search bar and click button to search :wink:

That didn’t work … how heartbreaking that NEM is so difficult and complex as I have probably lost my assets. I deal with a number of other wallets that are easy to operate … so wonder why NEM is so complex and unforgiving. I did record my Primary Private Key … but the address that comes up with a zero balance is different from what I have recorded. I have the original .wlt file but don’t know if that data is being accepted when I try to set up a simple wallet in order to retrieve my assets. How can I know what private key that the .wlt file is apparently supposed to provide so that a new simple wallet will open with the correct balance?

If you have your old wlt file you can just import it. Of course you need to put correct password.
You have import option when you go to login page (big yellow button)

When I import the wallet DJ147 with the password and the .wlt file, I get a wallet that has a zero balance. How can that be? I am sure this is the original wallet created 9/27/2019 and the .wlt file of the same name … which received a substantial quantity of NLC2 coins. I discovered that the coins were missing in mid March of this year.

What’s the address of imported wallet?

The address of my imported wallet is …


This wallet is empty and don’t have any transaction:

What are NLC2 coins?

Sorry … I misspoke. I am working on several nightmare wallets in addition to the NEM wallet. NLC2 coins are from another wallet where I cannot retrieve my assets. Very frustrating and this leads to confusion. I meant to say XEM coins. Okay … the wallet is empty and doesn’t have any transactions. This wallet was created on 9/27/2019 … in my notes I see that the day before, I set up another wallet but noted that it had been superseded. Perhaps that is where the XEM is stored. Will send that address to you shortly.

Please reference the above message. Don’t know what I’m doing wrong, but when I try to open the superseded wallet, I can neither sign in or import the wallet. I have the .wlt file, but the name of this wallet does not show in the “Select Wallet” in local storage window. How do I get that wallet name into this window?

You should import wlt file. If all will be ok it should show in selectbox on login page.

When I import this .wlt file I get the message “A wallet with that name is already loaded” … but it does not show in the select box

This probably happend because your old and new wallet had same name. And importing new wallet failed. If you have backup of your ALL wlt files then you can prune wallets (trash icon in bottom right corner) which remove all wallets from local storage. You should be able now import wallet.

I purged all wallets in local storage and then attempted to import wallet. The name of the .wlt file showed in a small box briefly off to the right side of the “Import Wallet” button … but not in the Select Wallet box. When I attempted to sign in, a green window opened that said the walled was successfully loaded, but now the wrong wallet name shows up in the Select Wallet box.

You must give me some screenshots because I’m not sure if I understand. So you imported this wallet and what address it has when you log in?

Don’t know why, but this time I was able to get the original account name to show in the select box and the password was accept. However, my XEM coins are not shown in the balance.
Attached is a screen shot showing the account.NEMaccount|690x394

It’s same address as before:

That’s right ( the address is the same) and its one of the reasons that I’m very confused. Looking at the written notes on my NEM wallet, it appears that I established it on September 26th, 2019. For some unknown reason, I superseded the wallet on the 27th with a new name and password. I’m not sure when I deposited over 5,000 XEM to the wallet, but I actually saw it in place. At some later point, the XEM disappeared and in a panic, I updated to version 2.4.4 and created a new wallet and password. Still no luck. With no balance showing, I was not able to look at any transactions that might explain what happened. Unfortunately I wasn’t paying enough attention to this wallet. I have opened the panic created wallets and they all shown no balance. What could have happened to my XEM coins?