Error 699 harvesting limit hit on local host

I got the same problem as thread starter Error: 699 Harvesting limit hit.

Yesterday harvesting worked I suppose because it was the first time I tried. I clicked the started harvesting button and I got no error messages so I think harvesting started. Should there happen something special while harvesting that notifies me that I am doing harvesting? The only thing I noticed is that “Start delegated harvesting” button changed to “Stop delegated harvesting” Shouldnt my number of XEM:s increase if I have done harvesting?

1 Like

if the button says “stop delegated harvesting” then you are still harvesting. in many cases if you close the wallet, but not the NIS, the NIS will still be running in the background harvesting for you. it is also very light. like on my computer it might be using 1%-2% of my processor when I check.

I have the same problem “ERROR 699 NIS: HARVESTING LIMIT HIT”.

I have tried changing “nis.unlockedLimit = 1” to 2 then 5 and 15 :-).
This didnt work and still gives me the same error.

But then I tried a new node from nodeexplorer and this helped!

I’m a happy harvester now

That only has influence if you are connected to a local nis. From what you say you are using a remote nis.

Oh ok. Sorry :slight_smile:


I am new to the Nem community. A couple off days ago I opened an coount and funded it. I have waited untill my vested Balance was over 10.000 XEM.

I did an importance transaction

Jun 27, 2016 23:51:59	NACJQ4-BHE5RU-KTFE2W-KVQTIC-673OQP-XCTJEU-DLMF	n/a	n/a		View	3811	10.00

When I start delegated harvesting I receive Error 699.

I did not started local harvesting before and the importance score is 0.0/000

Is there something which I have to do to get things running?

Which version are you running? 0.6.77 comes with a harvesting limit of 4 harvester which should be enough. In case you already had a version installed you might need to raise the limit by editing the file in the NIS sub-folder.
The entry that controlled the limit is
nis.unlockedLimit = 4
If you got a limit of 1 then set it to 4 and save the file. Restart NIS after that.

The above is only valid if you are running NIS and connect locally to that NIS. In case you use a remote NIS you should just try to use another remote server.

I have 0.6.77 running.
using another remote server means just sending an importance transaction to another server?

no, you just change the settings :slight_smile:
The settings are available on the left side.

Ok I will try another :wink:



which server are you using?

after the change

AltusHost B.V. Nexus 6 d70608e4-eb1f-40d2-ae9

try there seems to be one spot left on that vps.

Which number on the list?
I scrolled twice :wink:

never mind I used Google and found it.

this time no error :slight_smile:


You can just use as entry for the field ‘host’.