NEM Beta 0.5.19


#1

Beta 0.5.19 is here!

(Can you feel the heat?)

[hr]

Changes:


    [li]additional nis api, see http://bob.nem.ninja/docs/ for details (v1.6)[/li]
    [li]some internal block related changes[/li]
    [li]LOT of closed issues (doesn't mean solved ;)):

      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/239[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/241[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/243[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/244[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/245[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/246[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/247[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/249[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/250[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/251[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/252[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/256[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/257[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/259[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/262[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/265[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/268[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/269[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/270[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/271[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/273[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/275[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/283[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/284[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/287[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/290[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/292[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/295[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/297[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/298[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/299[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/300[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/306[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/311[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/315[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/317[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/320[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/322[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/326[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/328[/li]



      [hr]

      NEM requires Java 8
      You can start NCC and NIS with an installer from the following link:
      http://bob.nem.ninja/installer/
      Standalone version: http://bob.nem.ninja/

      [hr]

      Enjoy the new version :slight_smile:

#2

uh oh  :o

https://www.dropbox.com/s/et2d9zc3ch1ljv6/nis-0.log?dl=0

I was trying to run the stand alone and had a crash of NIS.

Edit:  some how it seems like old files are getting mixed up with new files.  Basically what happens is that I have a folder on my desktop called "package".  Then I am asked if I want to replace it when I am unzipping the latest version.  I click yes.  But somehow so old files get mixed in or something.  Not sure

Edit 2: Deleting the NEM folder in my user folder and deleted the package folder on my desktop.  logged in with my old wallet pasted back into NCC.  Syncing a new chain and things look good so far.

Edit 3:  I am pretty sure I am not suppose to have 65% POI. 


#3

It's not %, it was switched to this: http://en.wikipedia.org/wiki/Basis_point


#4

It's not %, it was switched to this: http://en.wikipedia.org/wiki/Basis_point


Okay.  that makes sense then.  It will be a little bit confusing for some people to get use to that have been beta testers, but shouldn't be too hard.  I do have to say that symbol is confusing to me though.  I wasn't aware of it, nor do I think any of the people I am close to would understand it.  I think it is maybe just for math or business people?

I'd almost just suggest removing the symbol all together and just having the PoI number. 

Update on my earlier status, a new blockchain is synced and the spammer has been turned on and is working.  I'll test more later. 

#5


It's not %, it was switched to this: http://en.wikipedia.org/wiki/Basis_point


Okay.  that makes sense then.  It will be a little bit confusing for some people to get use to that have been beta testers, but shouldn't be too hard.  I do have to say that symbol is confusing to me though.  I wasn't aware of it, nor do I think any of the people I am close to would understand it.  I think it is maybe just for math or business people?

I'd almost just suggest removing the symbol all together and just having the PoI number. 

Update on my earlier status, a new blockchain is synced and the spammer has been turned on and is working.  I'll test more later.
I agree, the average user will be confused, sometimes simple is better.

#6

Is there a guide somewhere to update without muddling the old files. Is it possible is keep old wallets or do I have to start everything over again?
You keep old wallets. The only file you have to worry about is the config.properties file, this will get overwritten with the new one. If you haven't made any changes to it then you will be fine. If you have made changes to it just save a copy, install new beta and copy old config file.

Look in here if you need more help: https://forum.ournem.com/tutorials/

#7



It's not %, it was switched to this: http://en.wikipedia.org/wiki/Basis_point


Okay.  that makes sense then.  It will be a little bit confusing for some people to get use to that have been beta testers, but shouldn't be too hard.  I do have to say that symbol is confusing to me though.  I wasn't aware of it, nor do I think any of the people I am close to would understand it.  I think it is maybe just for math or business people?

Update on my earlier status, a new blockchain is synced and the spammer has been turned on and is working.  I'll test more later.
I agree, the average user will be confused, sometimes simple is better.


There will be > 1000 stakeholders in nemesis. Bip is the only unit that makes some sense.

If we'd just show importance, most people would see 0,00025. Does that look good?

#8




It's not %, it was switched to this: http://en.wikipedia.org/wiki/Basis_point


Okay.  that makes sense then.  It will be a little bit confusing for some people to get use to that have been beta testers, but shouldn't be too hard.  I do have to say that symbol is confusing to me though.  I wasn't aware of it, nor do I think any of the people I am close to would understand it.  I think it is maybe just for math or business people?

Update on my earlier status, a new blockchain is synced and the spammer has been turned on and is working.  I'll test more later.
I agree, the average user will be confused, sometimes simple is better.


There will be > 1000 stakeholders in nemesis. Bip is the only unit that makes some sense.

If we'd just show importance, most people would see 0,00025. Does that look good?
That makes sense but the average user will be still confused, but I guess they might feel better seeing whole numbers rather then  0,00025.

#9

Just put a little [?] link next to ‱ and when a user hovers over it, a tooltip is displayed, which says:
1 ‱ = 0,1


#10

After some discussions at telegram, we came to the conclusion that we should drop ANY units for the importance score.

Having


#11

Agree completely. Another pointis that the guys with high scores will very likely reduce that number in time.

Another point again…we need scores to be as simple as possible for average joes to compare their scores with others. We want people to compete with each other for higher scores.


#12

I am not sure it is good to have no unit behind the number. People will start asking what the number means. And if not, the most probably association is that this is the number of block he thinks he will harvest per day.


#13

and no one commented on closed issues…


#14

and no one commented on closed issues....

[img width=317 height=300]http://fc09.deviantart.net/fs71/f/2010/149/0/8/sad_panda_chibi_by_mshydeplz.png[/img]
Good job on those bugs devs!

Big Hugs and  :-* :-* :-* :-

#15


and no one commented on closed issues....

[img width=317 height=300]http://fc09.deviantart.net/fs71/f/2010/149/0/8/sad_panda_chibi_by_mshydeplz.png[/img]
Good job on those bugs devs!

Big Hugs and  :-* :-* :-* :-


Yeah, well done :D

#16

Copy address to clipboard dont work with last version of Adobe flash player  today I update player for Mozilla Firefox 37.0 beta Windows 7 Ultimate 32 bit standalon version


#17

Me too.  " Copying an address requires flash. "
I update and reboot my system then I install the new version 0519. Up to date version Adobe Flash Player 11.2.202.451 linux , Mozilla Firefox 36.0.
Firefox to old ?


Important status = maybe  a colour bar with ten different small units / colours.


#18

oh sorry to fast…

or maybe a pie graph in the style of NEM ?


#19

Me too.  " Copying an address requires flash. "
I update and reboot my system then I install the new version 0519. Up to date version Adobe Flash Player 11.2.202.451 linux , Mozilla Firefox 36.0.
Firefox to old ?


Important status = maybe  a colour bar with ten different small units / colours.


same issue on Chrome Version 41.0.2272.89. Latest flash

#20

Has a bug(?) in the NCC, it closes when i try to start it previously configured to access a temote NIS, which no longer exists.