NEM Beta 0.6.30, 0.6.31


#1

[center]


0.6.31 is here![/center]

[hr]

There was a bug in 0.6.30 in translations, that disabled all other translations, we're sorry about that.
That's been fixed, and here's 0.6.31 for you.

P.S. updated docs: http://bob.nem.ninja/docs/

P.P.S. if you had problem with visibility of the blocks that you've harvested, synching from scratch should fix the issue.

[hr]

Mostly contains fixes in UI + some additional APIs.
therefore it's not mandatory, but we suggest to upgrade

Most important changes:


    [li]Export should be working fine now, keep in mind, that ncc does not use brainwallet, and there aren't deterministic wallets as of now, so whenever you add new account to the wallet, you should make a export a backup.[/li]
    [li]Few new APIs in nis, but documentation is missing, we'll try to update it #soon (/account/get/forwarded, /account/get/from-public-key, /account/get/forwarded/from-public-key)[/li]
    [li]Full list of closed issues (it might look big, but most of them are small chages):

      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/242[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/303[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/350[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/354[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/357[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/359[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/361[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/363[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/365[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/371[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/373[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/383[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/395[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/405[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/409[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/412[/li]
      [li]https://github.com/NewEconomyMovement/NemCommunityClient/issues/415[/li]

      [/li]

      [hr]


      NEM requires Java 8
      Remember installer requires 64-bit java
      You can download java from official page: [url=http://java.com/en/download/manual.jsp]http://java.com/en/download/manual.jsp


      You can start NCC and NIS with an installer from the following link:
      [url=http://bob.nem.ninja/installer/]http://bob.nem.ninja/installer/
      Standalone version: [url=http://bob.nem.ninja/]http://bob.nem.ninja/

      bonus image from http://nembex.nem.ninja/#/statistics/:

#2

Nice  :)  Thanks gimre!


#3

Nice!  :slight_smile:


#4

Looks great! Some good fixes to NCC should make life easier.


However at least Japanese doesn't work (I only tried English and Japanese).


#5

So I'll wait for the next wallet … if my NIS does not fall first.  :stuck_out_tongue:
Gook work!


#6

Nice. So after 0.6.26, it is 0.6.30? Do I have to sync the blockchain again?


#7

Приветствую. Вот такие проблемы у меня в новой версии 0.6.30. В 0.6.28 таких проблем не было. Скрин приложил.


#8

Nice. So after 0.6.26, it is 0.6.30? Do I have to sync the blockchain again?

Nope, just save your config files, update nem package and copy back your config files - done ;)

#9

Nice. So after 0.6.26, it is 0.6.30? Do I have to sync the blockchain again?


Unless I was dreaming there was 0.6.28 for quite some time.

#10

Excellent Work Developers You guys are doing Awesome Work!


#11


Nice. So after 0.6.26, it is 0.6.30? Do I have to sync the blockchain again?

Nope, just save your config files, update nem package and copy back your config files - done ;)


There are new parameters in the NIS Config.

#12



Nice. So after 0.6.26, it is 0.6.30? Do I have to sync the blockchain again?

Nope, just save your config files, update nem package and copy back your config files - done ;)


There are new parameters in the NIS Config.

Really? I don't see them - I just see another description. But I didn't use diff or something ;)

#13

Cool! :slight_smile:


#14

Good News! :smiley:


#15

Good Stuff!


#16

Hi,


I'm went from 0.6.26 to .31 and now I'm not able to cut&paste the private key in NCC dialog "add existing account".


Since I have a second wallet were I archive accounts I don't use anymore it is important for me to have this function.


FireF




#17

What do you mean with "can't cut and paste" in the "add existing account" dialog? Does the pasted key not appear in the field?


#18

Hi,


I'm went from 0.6.26 to .31 and now I'm not able to cut&paste the private key in NCC dialog "add existing account".


Since I have a second wallet were I archive accounts I don't use anymore it is important for me to have this function.


FireF


If you're really trying to cut then you might wanna try copy instead. I think if you try to cut something that isn't cutable (if that is a word Oo) then it won't even be copied therefore there is nothing in the clipboard hence you can't paste it.

#19

What do you mean with "can't cut and paste" in the "add existing account" dialog? Does the pasted key not appear in the field?





Sorry I mean copy & paste. On my mac its "Command Key + V" and this doesn't work. If I paste via "Menu" it works.




#20

I just tried it and on windows it works using ctrl+v. So I am not sure why you have that issue.