NEM Beta 0.6.93


Looking at the log I just noticed this:

2017-08-01 18:36:27.461 INFO auto harvesting with 'ND77X4BXLFRQMJIGS3L4YQZE5PBUCCYIWZGDM4CT -> ‘FAILURE_UNKNOWN_ACCOUNT’ (org.nem.nis.boot.HarvestAwareNetworkHostBootstrapper b)

Did a search and there’s no sign of that address so looks like they sent me an invalid delegated private key. Thanks again for all of your help today.


Hi so I deactivated the delegated harvesting last night.

To reactivate harvesting, which key/address do I place in the ‘manage delegated account’ section?

I have searched everywhere for this information, and wasted half of yesterday.
When going to and selecting my node - then test, I get ‘this site can’t be reached’


you don’t specify a custom key. Just use the data that is provided by Nano Wallet with mode Activate.


You need to activate delegated harvesting in Nano, then you will be able to start delegated harvesting with Nano.
When you activated the new delegated key in Nano, the config for your supernode needs the new key too, both NIS and servant. Also i need to manually make a new entry in the database.
i guess this one is your:


Hi yes that links to me.

So do I leave the remote account as it is, or do I tick ‘custom key’ then add my old NCC address - then activate?

Sorry to keep asking questions, but I want to be sure


You could use the old ncc delegated public key as custom key, but then why did you deactivate in the first place?


Lol I’m not sure now. I was following the above info given earlier in the thread.


So, you have the choice. Either use “custom key” supplying the ncc delegated public key or activate using the default data in which case the supernode entry has to be renewed.


Ok I think I am getting my keys mixed up.

When I enter what I think is my ncc delegated public key (using custom public key option)

It then shows the account I am familiar with - NCHSG- etc in th remote account box.

I select activate, and input my password

Then I get a red message saying FAILURE DESTINATION ACCOUNT IN USE :frowning:


That means you entered the main account’s public key, not the delgated public key.


Right I think I found it.
The client accepted it - which is progress.
Have activated harvesting, so I guess will wait and see.
Thank you BloodyRookie for your patience


My harvesting status on my nano wallet still shows as inactive, after approximately 8 hours.

The remote status now shows as active, where as before it said activating.

If I attempt to change anything in the nodes list - for example insert localhost, I can’t see my wallet, and the red circle is back.

I am about to give up on this. I have searched all over this forum, and googled.

Whilst I appreciate the help I have received here, it would be helpful if there was a clear guide for Supernode accounts, as to how to transfer from the old NCC account to the Nano wallet not just this - which just addresses the exporting part, not the setting up afresh.

I am sure it is easy if you know how :confused:


well, did you actively select a node in the harvesting screen and click on “start delegated harvesting”?
or are you harvesting on your supernode and expect Nano Wallet to magically know about it?


lol ok when I select a node to harvest with then click ‘start delegated harvesting’ a red message says something about my ip address attempted to unlock account with non remote address.

It flashes up quickly then disappears


Does Nano show NBZWS2-75L25K-PEU5MQ-6M4P4S-FUCOL4-2A34F6-EYHX as delegated account?


No account address starts with - NCHSGY-GX5BOI-ME7HUQ

and then in the ‘manage delegated account’ section there is a remote account address that starts NCNDJWVJRE

and on the right where it says ’ delegated account key’ there is nothing there

underneath there is a public key (delegated public key) and that is filled in


Asking QM as he knows Nano better…




Hi @nevermined,

Let’s restart from the beggining:

You have an old NCC account and you were harvesting:

In this case you must deactivate the old NCC remote account and activate the new Nano Wallet remote account.

For disabling the old remote:

  • Take the old NCC remote account public key
  • In Nano manage delegated account, you check use custom key, paste the key, check that it is indeed the right remote account, select deactivate and send.

6 hours later, once the old remote is disabled, you just go to manage delegated account in Nano and activate the new remote. Don’t enter any key or else, you just select activate and send, the new account will be the one that is displayed in the form and is unmodifiable.

6 hours later, once the new remote is activated, you should be able to select a node and start harvesting


Hi yes I saw a post earlier this year from Generaattori who had a similar situation

I have just deactivated the account again using the custom key option