NEM Supernode Command Line Tutorial for Debian 8.4


#104

Glad you’ve figured it out. I was going to suggest a retry from scratch next :wink:


#105

@Paul manymany thanks

Using your guide third time already. It should be an official one and should be placed in docs, not on forum.

Thanks again man.

The only thing that stamples me every time is what the heck is delegated private key and where to get it. I always put personal private key :wink:


#106

@Denis_Matafonov
You can find delegated private key in nanowallet.
Services > Manage delegated account > put password and click plus button do reveal delegated private key


#107

do i have to use Debian 8.4 or can I use the latest version?


#108

for what? Use a current OS. This is just a guide …


#109

What can I do to solve the “Chain Part” Problem? My SN stops to sync every few weeks and then fails the Tests. Normally a reboot helps, but anyway, it’s a recurring Problem. Is it just me or is there a solution to this?

Thank You!


#110

Yes I’ve had the same issue … dont really know what the answer is


#111

Hello,
How your start script looks like? How much memory is available on your host?


#113

My start Script, just copy pasted:

#!/bin/bash

cd nis
java -Xms1408M -Xmx1408M -cp ".:package/nis:package/nis/*:package/libs/*" org.nem.deploy.CommonStarter
cd -

But the Server has 4GB Ram. It’s a CX30 at Hetzner.


#114

If you have 4G available I would increase memory. 2.5 - 3G and check if this still happens.


#115

Thanks, increased to 2.5G. Let’s see what will happen.


#116

Guide was updated to the latest version 0.6.96 (NEM Beta 0.6.96). Also check your memory settings. It is now recommended to assign 2800MB to NIS.


#117

Have some trouble with par. 1.6
Got an error:
crontab: installing new crontab
“/tmp/crontab.xk3QLg/crontab”:24: bad minute
errors in crontab file, can’t install.
Do you want to retry the same edit? (y/n)

And one more error
wget http://bob.nem.ninja/nis5_mainnet-1680k.h2.db.zip
should be
wget http://bob.nem.ninja/nis5_mainnet.h2-1680k.db.zip


#118

Thank you. I fixed the mainnet dump file name. I double checked the crontab command and it works. This is what it should look like:


#119

When I try to download the supernode starter service, it gives the following error:
ERROR: The certificate of ‘github.com’ is not trusted.
ERROR: The certificate of ‘github.com’ hasn’t got a known issuer.

How to solve this issue? Thanks.

EDIT : To be precise, it gives the following error:
When i type the following command to download the supernode starter service :
wget https://github.com/PaulRieger/supernode-service/archive/master.zip.
I get the following error:
converted ‘https://github.com/PaulRieger/supernode-service/archive/master.zip’ (ANSI_X3.4-1968) -> ‘https://github.com/PaulRieger/supernode-service/archive/master.zip’ (UTF-8)
–2018-09-08 07:18:06-- https://github.com/PaulRieger/supernode-service/archive/master.zip
Resolving github.com (github.com)… 192.30.253.113, 192.30.253.112
Connecting to github.com (github.com)|192.30.253.113|:443… connected.
ERROR: The certificate of ‘github.com’ is not trusted.
ERROR: The certificate of ‘github.com’ hasn’t got a known issuer.


#120

…mmhhh, maybe try this …" sudo apt-get install ca-certificates " ,


#121

Thank you, this worked:+1: