NEM Supernode Rewards Program


#2761

Your new nodes are not showing the delegated public keys that you enrolled with, please check.


#2762

thank you!


#2763

@BloodyRookie
My supernode is running but failing all the tests after change ip.
Message was send, and everything looks ok. Please check it.
http://62.113.254.99:7890/node/extended-info
https://supernodes.nem.io/details/973


#2764

The ip in the db was not changed. when did you send the message? Can you give me the tx hash?


#2765

24 december, 9f21e08ccf0f7473c169e4b8d3f2b7a42f76ebc6fd3f1e3a1c7f764f84979512


#2766

I don’t see any such transaction in the main chain.


#2767

Strange, in account it confirmed.
Send message again:
http://explorer.nemchina.com/#/s_tx?hash=24f03de4329cfc0647ee7ab43a4dd8e46588bac51bc519dd19830c1b8a976650


#2768

Oh, you are right, nembex is the problem. But your message states that old ip is 23.163.0.42 and the db has ip 45.56.162.254 for entry with alias fortune. That is why the ip wasn’t changed i guess.


#2769

Oh, i send message to change ip from 45.56.162.254 to 23.163.0.42 early.
http://chain.nem.ninja/#/transfer/b54aafc541bf2b803dfad2b4c01c40d24b0786af587539a18974b094fd76b1df
but don’t control that it change.
Can you fix it or i need to send new message?


#2770

Changed ip manually. Should be ok now.


#2771

Thank you. It’s work. Happy New Year! )


#2772

Hi, BR, what’s happened with SuperNode measuring among 2019-01-06 12:58 GMT and 2019-01-07 09:14 GMT ?


#2773

The result evaluation task was stuck. I fixed it.


#2774

Did you find any workarounds after that? My SN also suddenly started failing by responsiveness.
My SN locates in Japan, too.


#2775

I resolved it by changing the server to a different company.


#2776

Good to hear the solution. Thanks! :grinning:


#2777

My SN is failing intermittently on computing power and version. Version is 0.6.96 BETA. Has 4 GB RAM, and two CPUs. Memory usage was around 80% usage by Java, and also have a 1GB swap file.

nis starts Java with parameters: -Xms2800 and -Xmx2800

Any idea why these version and computing power would be failing?


#2778

After reboot shows as below while chain is loading:

%Cpu(s): 26.3 us, 0.1 sy, 0.0 ni, 41.0 id, 0.9 wa, 0.0 hi, 0.1 si, 31.6 st
KiB Mem : 4044748 total, 492100 free, 2332472 used, 1220176 buff/cache
KiB Swap: 1048572 total, 1048572 free, 0 used. 1473308 avail Mem


#2779

that probably leads to using part of the swap memory which is slow.
Try to use -Xms2500 and -Xmx2500 if we will see if it works better.
Also be sure to restart NIS every few weeks.


#2781

I’ve tried changing to 2500 but still failures on computing power.

This is the output from top:

%Cpu(s): 48.4 us, 0.0 sy, 0.0 ni, 0.6 id, 0.0 wa, 0.0 hi, 0.0 si, 51.0 st
KiB Mem : 4044748 total, 160808 free, 3168840 used, 715100 buff/cache
KiB Swap: 1048572 total, 1041056 free, 7516 used. 629260 avail Mem

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
1264 root 20 0 5174272 2.757g 11292 S 198.0 71.5 1068:00 java

CPU shows as 48.4% in the summary, but above shows 198.0%
Also memory is 71.5% usaed by Java.

Should I lower 2500xms/xmx to a different value?