NEM Supernode Rewards Program


#2804

Thanks! I will use ip change message next time.


#2805

Is 8GB recommended now with the -Xms5G -Xmx5G settings?
Where does the garbage collector line go, same as above?

I only have 4GB and it fails every so often …


#2806

Generally the more RAM the supernode has, the better it is. Also, with 8GB and more the G1 garbage collector should be preferred, else the “stop the world” events for garbage collection tend to take too long.
The above settings are the standard settings,

-Xms5G -Xmx5G -XX:+UseG1GC -XX:MaxGCPauseMillis=200

i use them for the 8GB nodes i have, they work well.
4GB might still work, but you have to restart NIS every now and then.


#2807

any option to increased rewards for super nodes?


#2808

No, will stay like that.


#2809

Any idea why chain height is stuck on 20133303? I have been experimenting with different xms xmx settings due to previous computing power failures. I lowered to 2500 initially same issue. Then tried different settings until 2048. Which fixed computing power, but failed height. I tried 2100, 2200, 2300. Recently been failing height, now changed to 2400 this morning. Ram is 4gb with 1gb swap.


#2810

Hard to tell without log, maybe low on memory or db corruped?


#2812

On the nis log when loading blocks it gets to loadBlocks from height 2013304 to height 2013403, then next line is clustering completed.

I would suspect this should continue loading blocks but doesn’t. Is there a way to reset this, i.e. remove and reload entire chain?


#2813

Block loading completed ; height 2013303 …Blockchain last block layer)


#2814

so it completed loading the chain, then what happens next? does it sync?
Would be esier to upload the complete log to a file hoster and paste a link here.


#2815

Hi BloodyRookie, I’ve sent you a link to the log file.


#2816

On a separate note, would deleting the nis5_mainnet.h2.db then restarting nis re-download the whole file (presuming if the db was corrupted).

What is the command to stop nis? I usually reboot, and use the script to start nis, but haven’t manually stopped nis due to not knowing the command.


#2817

No need to sync from scratch. Your node was syncing according to the log and was finally synced 2 hours ago. But it seems to be offline right now? At least i cannot retrieve the chain height…


#2818

when will the database dump be updated on bob.nem.ninja?

Last one was June 2018


#2819

ok will do that soon.


#2820

Thanks for looking into this. It shouldn’t be offline, I’ve just checked and it has been online for quite a while. You probably not being able to see the chain height might indicate the reason why it’s failing on chain height.


#2821

Maybe. could it be that your config is holding the old ip and that autodetecting the ip is disabled?

Edit: Seems autodetecting ip is enabled but please check ip in config.


#2822

Which file is the config one, is it config-user.properties or config.properties. I’ll have a check.


#2823

config-user.properties if you have one.


#2824

Current db is on bob:
bob.nem.ninja/nis5_mainnet.h2-2015k.db.zip