(automated delegated harvesting, export of transactions and more!)

I have no exact deadline but the sooner the better. If you can’t make it in time I will just look for another way, don’t worry.

I can prepare it for you. Ping me on telegram @cryptoBeliever

in case some of you missed it -> is back online with all past features. you can now provide a NEM-address in the settings which will be stored on your client and reused after visiting the nem-tools again

more information about the relaunch in my blog entry:

Have tried to sign up for automated delegated harvesting several times but haven’t received an email confirmation or which node to use.

I have over 10k XEM vested. Have already done the importance transfer transaction. Nano wallet is showing I have activated remote status and I can even activate my harvesting status by assigning to a specific node – but as soon as I log out & log back in, harvesting status is no longer active.


I will write you in personal messages to solve the problem :wink:


So I’m a bit new to all this so go easy please.
So I have recently just signed up to your automated harvesting and all seems to be working correct (amazing tool) but I’m a bit confused on a couple things.

Why does my email say a different Delegated Address to my Delegated Address on my nano wallet? or am i reading this wrong and reading the public key Address which is different to the Address.
If this is the case how can i check you have the correct delegated address? Obviously you have the private Delegated key so that’s no issue but just want to double check the Delegated Address to mine.

Also if i only have just over 10k vested what are the approx harvesting amounts for a year/month, rough answer is fine so i have a ball park figure as i have been doing delegated harvesting for 5 plus months now and haven’t even got one fee yet (understand though I was probably not active all the time) so hopefully now with your service it keeps me on 24/7 My importance is only 0.0829 * 10(-4) also which probably isn’t that great.


1 Like

all the NEM nodes run on http? Where are they located?

sorry for that late response. most of the NEM nodes run on http.

nem-tools is configured to read the data from https nodes. unfortunately there are some issues with pagination of transaction history when using the connection pool of nem-library.

therefore nem-tools only connects to one specific node (london.nemchina)

these are the https nodes that I know of:

Hi All! is not working for account.

Unfortunately there is some problem with the public available nodes running on https.

Depotwallet of DIMCoin posted a blog entry about that topic (

nem-tools is trying to connect to which cannot be accessed at the moment

hopefully it will soon be accessible again

I switched the node to and now it should work again.

1 Like

It is worked.


1 Like

Hi @marc0o I keep getting:
the private key you provided belongs to a non-remote address

Any ideas on this? Google provides no answers! Thanks :slight_smile:

yes, please be careful! it seems like to you put in a private key that belongs to a non-remote address that probably contains funds.

you should never publish the private key of an account the holds any funds.

in order to get automated restarts of delegated harvesting working you need to provide the private key of your delegated account (which doesn’t hold any funds and is only responsible for starting / stopping harvesting)

note: if your account has funds in it you should consider moving the funds to a new account (you will need to wait for you 10.000 XEM to be vested again in order to be able to use harvesting)

Definitely only provided the delegated key and not my account private key!

From this page.

The problem seems to be sorted as it has restarted successfully - are there any other reasons for this happening?

Yes. I got same error when I used lately Trezor delegated private key. Not sure if Dan case is same.

mhhh that really sounds strange. it’s difficult to check what went wrong if I don’t know what exactly happened.

@Dan_V if you got the mail that restart was successful then the service keeps track of your delegated account and you should always be harvesting. where have you got the error message you stated above? and you didn’t sign up again successfully after you got the error? so your account was registered although you received an error on frontend?

It basically said that the subscription was terminated and I can “sign up again”, my delegated harvesting had definitely stopped, So I resigned up and it seems to be working, since posting this I have had 2 restarts.

ok so that’s really a strange problem. either the node my service tried to start harvesting on had this error in the response or (what I currently cannot say for sure) my service cannot interpret the probably unknown error message.

but in any case -> just sign up again :wink: … if the account is able to harvest it should work.

if I find time I will have a look on that one. unfortunately I am not storing the logs so I cannot 100% say what was going on and due to the unexpected error-message this error is probably hard to reproduce.

thanks for your detailed description!

I’ve signed up again - ill see if anything else happens similar to this! So far its fine!

1 Like