[SOLVED] Trezor not connecting & Opt-in not finishing

Did an opt-in a month ago. Logged in with my Trezor One, all smooth.

Tried to access my NEM wallet today and it seems to get stuck after Trezor pop-up.

Did a Trezor One firmware update to latest, that did no help with the issue.

Trezor One works fine in Trezor wallet and other apps.

Any advice? Is this a a bigger 2.4.7-optin issue ? or Trezor One issue?

I don’t have issue with Trezor One.
If you have in browser extension for blocking ad try turn it off.
Check if pop-ups are not blocked. You can try also in other browser.

1 Like

Hello, I’ve the same problem as TulipMaina. After the pop-up which come two times, the dashboard is empty and no one nodes seems to be working, only red circle. I’using Trezor One and Chrome and JavaScript and Cookies are allowed. With 2.4.7-optin or with 2.4.4. the same problem. Please help.

Hello! I got it. I’ve changed the setting for the extension “HTTPS Everywhere” in Chrome to allow also not encrypted connections and it works!

1 Like

Awesome, I’ll try that, and report back.

I don’t use “HTTPS Everywhere” so this did not work for me.
Just to be clear, I’m getting stuck at “Export NEM address”
After I check for device and pair.
I tried on different browsers and computers, still nothing

Fixed it with a new bridge update from trezor support docs.
My old bridge worked everywhere else so didn’t think to update it.
Hope this helps anyone else with this issue.

1 Like

In a separate issue on the Opt-in Trezor was getting stuck in the fetching opt-in data.
Skipping VRF key part solved it! as mentioned in previous issues on the forum:>

VRF + balance opt-in opens two pop-ups and those are blocked by default by browser. VRF keys are not needed in most of cases but if you want include it just enable pop-ups :+1: