Error 699 harvesting limit hit on local host

I did some poking around the forum and I’m guessing I have the same problem that was addressed here:

Continuing the discussion from Wallet error message:

I had to also create a new wallet, so it’s very likely, even without checking my logs. I just deactivated delegated harvesting, and then will try to reactivate it again and hope it works. I’ll keep you posted (especially if it doesn’t work).

OK, I deactivated, then activated delegated harvesting and now it’s working.

I’m up and running again. Yay!

Yes, that tends to be a common problem and one we need to think through better.

If you have your private key for the delegated account you can harvest on any NIS if it is added to the config file. But if you are trying to harvest through NCC and have switched wallets, then it has to the deactivated and reactivated again.

Steep learning curve for me, so I’m asking questions that may seem stupid to others. I get the same 699 error message. I found the file in my package folder, but don’t know how to edit it in my Macbook Pro. I click the file — which is listed as a document file — and it asks me to choose an application to open it. I don’t believe Notepad is available to Mac users. Besides, even if I did open it in another program, it has to then be converted back to something that Java recognizes, yes?

FYI: I didn’t start with local harvesting. Started with delegated harvesting and am using a remote server and am still waiting to be vested. I’m wondering if the problem is essentially that the remote server isn’t taking on new folks, that it has established a limit and won’t let me join the club, so to speak. Possible?

Here you go How to Raise the Amount of Harvesters. Fix Error 699

In Mac the program you use to edit this file is called TextEdit.

It is a steep learning curve. Thanks for sticking with it. Later, it will be much easier for users.

Thx for helpin’ a brother out. Made the change. Once I’m vested, we’ll see if this does the trick.

sounds great

I got the same problem as thread starter Error: 699 Harvesting limit hit.

Yesterday harvesting worked I suppose because it was the first time I tried. I clicked the started harvesting button and I got no error messages so I think harvesting started. Should there happen something special while harvesting that notifies me that I am doing harvesting? The only thing I noticed is that “Start delegated harvesting” button changed to “Stop delegated harvesting” Shouldnt my number of XEM:s increase if I have done harvesting?

1 Like

if the button says “stop delegated harvesting” then you are still harvesting. in many cases if you close the wallet, but not the NIS, the NIS will still be running in the background harvesting for you. it is also very light. like on my computer it might be using 1%-2% of my processor when I check.

I have the same problem “ERROR 699 NIS: HARVESTING LIMIT HIT”.

I have tried changing “nis.unlockedLimit = 1” to 2 then 5 and 15 :-).
This didnt work and still gives me the same error.

But then I tried a new node from nodeexplorer and this helped!

I’m a happy harvester now

That only has influence if you are connected to a local nis. From what you say you are using a remote nis.

Oh ok. Sorry :slight_smile:


I am new to the Nem community. A couple off days ago I opened an coount and funded it. I have waited untill my vested Balance was over 10.000 XEM.

I did an importance transaction

Jun 27, 2016 23:51:59	NACJQ4-BHE5RU-KTFE2W-KVQTIC-673OQP-XCTJEU-DLMF	n/a	n/a		View	3811	10.00

When I start delegated harvesting I receive Error 699.

I did not started local harvesting before and the importance score is 0.0/000

Is there something which I have to do to get things running?

Which version are you running? 0.6.77 comes with a harvesting limit of 4 harvester which should be enough. In case you already had a version installed you might need to raise the limit by editing the file in the NIS sub-folder.
The entry that controlled the limit is
nis.unlockedLimit = 4
If you got a limit of 1 then set it to 4 and save the file. Restart NIS after that.

The above is only valid if you are running NIS and connect locally to that NIS. In case you use a remote NIS you should just try to use another remote server.

I have 0.6.77 running.
using another remote server means just sending an importance transaction to another server?

no, you just change the settings :slight_smile:
The settings are available on the left side.

Ok I will try another :wink:



which server are you using?